summaryrefslogtreecommitdiff
path: root/dev-util/gnome-builder/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-util/gnome-builder/files
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-util/gnome-builder/files')
-rw-r--r--dev-util/gnome-builder/files/3.28.4-fix-docs-option.patch42
-rw-r--r--dev-util/gnome-builder/files/3.28.4-fix-tests-schemadir.patch26
-rw-r--r--dev-util/gnome-builder/files/3.28.4-jedi-0.12-compat.patch93
-rw-r--r--dev-util/gnome-builder/files/3.28.4-python37-fix.patch57
-rw-r--r--dev-util/gnome-builder/files/3.28.4-valac.patch15
5 files changed, 233 insertions, 0 deletions
diff --git a/dev-util/gnome-builder/files/3.28.4-fix-docs-option.patch b/dev-util/gnome-builder/files/3.28.4-fix-docs-option.patch
new file mode 100644
index 000000000000..ca2323f314a0
--- /dev/null
+++ b/dev-util/gnome-builder/files/3.28.4-fix-docs-option.patch
@@ -0,0 +1,42 @@
+From 054ef6d2e47da9f41e7c24908b251d074e11a03b Mon Sep 17 00:00:00 2001
+From: Christian Hergert <chergert@redhat.com>
+Date: Wed, 8 Aug 2018 13:03:50 -0700
+Subject: [PATCH] help: fix get_option() to check for proper value
+
+We want to check for help docs, not sdk docs. Also, if enabled, don't be
+automatic about it. Fail hard so the caller knows there is an issue.
+---
+ doc/help/meson.build | 18 ++++++++----------
+ 1 file changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/doc/help/meson.build b/doc/help/meson.build
+index 1336e6a26..e684f078c 100644
+--- a/doc/help/meson.build
++++ b/doc/help/meson.build
+@@ -1,15 +1,13 @@
+-if get_option('with_docs')
++if get_option('with_help')
+
+-sphinx = find_program(['sphinx-build-3', 'sphinx-build'], required: false)
++sphinx = find_program(['sphinx-build-3', 'sphinx-build'], required: true)
+
+-if sphinx.found()
+- custom_target('en user documentation',
+- command: [sphinx, '-b', 'html', '-c', meson.current_source_dir(), meson.current_source_dir(), '@OUTPUT@'],
+- output: 'en',
+- build_by_default: true)
++custom_target('en user documentation',
++ command: [sphinx, '-b', 'html', '-c', meson.current_source_dir(), meson.current_source_dir(), '@OUTPUT@'],
++ output: 'en',
++ build_by_default: true
++)
+
+-
+- install_subdir(meson.current_build_dir() + '/en', install_dir: pkgdocdir_abs)
+-endif
++install_subdir(meson.current_build_dir() + '/en', install_dir: pkgdocdir_abs)
+
+ endif
+--
+2.17.0
+
diff --git a/dev-util/gnome-builder/files/3.28.4-fix-tests-schemadir.patch b/dev-util/gnome-builder/files/3.28.4-fix-tests-schemadir.patch
new file mode 100644
index 000000000000..3c427c415841
--- /dev/null
+++ b/dev-util/gnome-builder/files/3.28.4-fix-tests-schemadir.patch
@@ -0,0 +1,26 @@
+From a66b2d99f21bff6986b0dda5b7cc9ee393be934a Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Wed, 29 Aug 2018 12:30:14 +0300
+Subject: [PATCH] build: Fix GSETTINGS_SCHEMA_DIR envvar handling in tests
+
+GSETTINGS_SCHEMA_DIR does not support multiple colon-separated paths.
+---
+ src/tests/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tests/meson.build b/src/tests/meson.build
+index 646f6f875..42c0e6d28 100644
+--- a/src/tests/meson.build
++++ b/src/tests/meson.build
+@@ -16,7 +16,7 @@ ide_test_env = [
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ 'G_DEBUG=gc-friendly',
+ 'GSETTINGS_BACKEND=memory',
+- 'GSETTINGS_SCHEMA_DIR=@0@/data/gsettings:$(GSETTINGS_SCHEMA_DIR)'.format(meson.build_root()),
++ 'GSETTINGS_SCHEMA_DIR=@0@/data/gsettings'.format(meson.build_root()),
+ 'PYTHONDONTWRITEBYTECODE=yes',
+ 'MALLOC_CHECK_=2',
+ # 'MALLOC_PERTURB_=$((${RANDOM:-256} % 256))',
+--
+2.17.0
+
diff --git a/dev-util/gnome-builder/files/3.28.4-jedi-0.12-compat.patch b/dev-util/gnome-builder/files/3.28.4-jedi-0.12-compat.patch
new file mode 100644
index 000000000000..4132e2d1bfef
--- /dev/null
+++ b/dev-util/gnome-builder/files/3.28.4-jedi-0.12-compat.patch
@@ -0,0 +1,93 @@
+From 799a378b96cad5dc9b1093604e76ed362d22f4cc Mon Sep 17 00:00:00 2001
+From: Christian Hergert <chergert@redhat.com>
+Date: Sun, 27 May 2018 20:19:34 -0700
+Subject: [PATCH] jedi: minimal attempt to get things working again
+
+This tries to get some of our jedi code working with recent API changes
+in the jedi project.
+
+This is just a minimal fix, and I'd expect some others may be needed for
+improved functionality.
+
+Fixes #403
+---
+ src/plugins/jedi/jedi_plugin.py | 44 ++++++++++++++++++++++-----------
+ 1 file changed, 29 insertions(+), 15 deletions(-)
+
+diff --git a/src/plugins/jedi/jedi_plugin.py b/src/plugins/jedi/jedi_plugin.py
+index fd8e15d68..052500da1 100644
+--- a/src/plugins/jedi/jedi_plugin.py
++++ b/src/plugins/jedi/jedi_plugin.py
+@@ -91,8 +91,14 @@ try:
+ import jedi
+ from jedi.evaluate.compiled import CompiledObject
+ from jedi.evaluate.compiled import get_special_object
+- from jedi.evaluate.compiled import _create_from_name
+- from jedi.evaluate.context import Context
++ try:
++ # 0.12
++ from jedi.evaluate.compiled import create_from_name
++ from jedi.evaluate.base_context import Context
++ except ImportError:
++ # Pre 0.12
++ from jedi.evaluate.compiled import _create_from_name as create_from_name
++ from jedi.evaluate.context import Context
+ from jedi.evaluate.docstrings import _evaluate_for_statement_string
+ from jedi.evaluate.imports import Importer
+
+@@ -175,23 +181,31 @@ try:
+ pass
+ return module_list
+
+- original_jedi_get_module = jedi.evaluate.compiled.fake.get_module
+-
+- def patched_jedi_get_module(obj):
+- "Work around a weird bug in jedi"
+- try:
+- return original_jedi_get_module(obj)
+- except ImportError as e:
+- if e.msg == "No module named 'gi._gobject._gobject'":
+- return original_jedi_get_module('gi._gobject')
++ try:
++ # Pre 0.12 workaround
++ # TODO: What needs to be fixed here for 0.12?
++ original_jedi_get_module = jedi.evaluate.compiled.fake.get_module
++ def patched_jedi_get_module(obj):
++ "Work around a weird bug in jedi"
++ try:
++ return original_jedi_get_module(obj)
++ except ImportError as e:
++ if e.msg == "No module named 'gi._gobject._gobject'":
++ return original_jedi_get_module('gi._gobject')
++ jedi.evaluate.compiled.fake.get_module = patched_jedi_get_module
++ except:
++ pass
+
+- jedi.evaluate.compiled.fake.get_module = patched_jedi_get_module
+ jedi.evaluate.compiled.CompiledObject = PatchedJediCompiledObject
+- jedi.evaluate.instance.CompiledBoundMethod = PatchedCompiledBoundMethod
++ try:
++ jedi.evaluate.instance.CompiledBoundMethod = PatchedCompiledBoundMethod
++ except AttributeError:
++ jedi.evaluate.context.instance.CompiledBoundMethod = PatchedCompiledBoundMethod
+ jedi.evaluate.imports.Importer = PatchedJediImporter
+ HAS_JEDI = True
+-except ImportError:
++except ImportError as ex:
+ print("jedi not found, python auto-completion not possible.")
++ print(ex)
+ HAS_JEDI = False
+
+ GIR_PATH_LIST = []
+@@ -376,7 +390,7 @@ class JediCompletionProvider(Ide.Object, GtkSource.CompletionProvider, Ide.Compl
+ return False
+
+ def do_populate(self, context):
+- self.current_word = Ide.CompletionProvider.context_current_word(context)
++ self.current_word = Ide.CompletionProvider.context_current_word(context) or ''
+ self.current_word_lower = self.current_word.lower()
+
+ _, iter = context.get_iter()
+--
+2.17.0
+
diff --git a/dev-util/gnome-builder/files/3.28.4-python37-fix.patch b/dev-util/gnome-builder/files/3.28.4-python37-fix.patch
new file mode 100644
index 000000000000..2fc6ee5be06f
--- /dev/null
+++ b/dev-util/gnome-builder/files/3.28.4-python37-fix.patch
@@ -0,0 +1,57 @@
+From e1d32d76231b1051a2380995f4a7822aa525375a Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@debian.org>
+Date: Wed, 11 Jul 2018 11:57:06 +0100
+Subject: [PATCH] Python: Avoid identifier 'async', which became a keyword in
+ 3.7
+
+This is an incompatible change, but so is async becoming an identifier.
+
+Fixes: #565
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=903558
+Signed-off-by: Simon McVittie <smcv@debian.org>
+---
+ src/libide/Ide.py | 6 +++---
+ src/plugins/jedi/jedi_plugin.py | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/libide/Ide.py b/src/libide/Ide.py
+index 02bb61937..07d429c7a 100644
+--- a/src/libide/Ide.py
++++ b/src/libide/Ide.py
+@@ -41,9 +41,9 @@ class _Gio_DBusMethodInfo:
+ in_args = None
+ out_signature = None
+
+-def DBusMethod(dbus_interface, in_signature=None, out_signature=None, async=False):
++def DBusMethod(dbus_interface, in_signature=None, out_signature=None, is_async=False):
+ def decorator(func):
+- func._is_async = async
++ func._is_async = is_async
+
+ func._dbus_method = _Gio_DBusMethodInfo()
+ func._dbus_method.interface = dbus_interface
+@@ -54,7 +54,7 @@ def DBusMethod(dbus_interface, in_signature=None, out_signature=None, async=Fals
+ in_signature_list = GLib.Variant.split_signature('('+in_signature+')')
+ arg_names = inspect.getargspec(func).args
+ arg_names.pop(0) # eat "self" argument
+- if async: arg_names.pop(0) # eat "invocation"
++ if is_async: arg_names.pop(0) # eat "invocation"
+ if len(in_signature) != len(arg_names):
+ raise TypeError('specified signature %s for method %s does not match length of arguments' % (str(in_signature_list), func.func_name))
+ for pair in zip(in_signature_list, arg_names):
+diff --git a/src/plugins/jedi/jedi_plugin.py b/src/plugins/jedi/jedi_plugin.py
+index 84bd11c27..a346a342e 100644
+--- a/src/plugins/jedi/jedi_plugin.py
++++ b/src/plugins/jedi/jedi_plugin.py
+@@ -688,7 +688,7 @@ class JediService(Ide.DBusService):
+ self.queue = {}
+ self.handler_id = 0
+
+- @Ide.DBusMethod('org.gnome.builder.plugins.jedi', in_signature='siis', out_signature='a(issass)', async=True)
++ @Ide.DBusMethod('org.gnome.builder.plugins.jedi', in_signature='siis', out_signature='a(issass)', is_async=True)
+ def CodeComplete(self, invocation, filename, line, column, content):
+ if filename in self.queue:
+ request = self.queue.pop(filename)
+--
+2.17.0
+
diff --git a/dev-util/gnome-builder/files/3.28.4-valac.patch b/dev-util/gnome-builder/files/3.28.4-valac.patch
new file mode 100644
index 000000000000..acb1c54f8519
--- /dev/null
+++ b/dev-util/gnome-builder/files/3.28.4-valac.patch
@@ -0,0 +1,15 @@
+diff --git a/src/plugins/vala-pack/meson.build b/src/plugins/vala-pack/meson.build
+index dd36d351d..a8c53c6e5 100644
+--- a/src/plugins/vala-pack/meson.build
++++ b/src/plugins/vala-pack/meson.build
+@@ -6,8 +6,8 @@ endif
+
+ add_languages('vala')
+
+-valac = find_program ('valac')
+-libvala_version = run_command(valac, '--api-version').stdout().strip()
++valac = meson.get_compiler('vala')
++libvala_version = run_command(valac.cmd_array()[0], '--api-version').stdout().strip()
+ libvala = dependency('libvala-@0@'.format(libvala_version))
+
+ vala_pack_sources = [