summaryrefslogtreecommitdiff
path: root/dev-util/goland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-03 18:18:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-03 18:18:28 +0000
commitfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (patch)
tree6be36785f6ffa594c4dbd785b3213c995b5195b9 /dev-util/goland
parent27dfd272ae3be15b1017f733682211afa1c7c0f0 (diff)
gentoo resync : 03.11.2017
Diffstat (limited to 'dev-util/goland')
-rw-r--r--dev-util/goland/Manifest3
-rw-r--r--dev-util/goland/goland-173.3531.21.ebuild45
-rw-r--r--dev-util/goland/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/goland/Manifest b/dev-util/goland/Manifest
new file mode 100644
index 000000000000..1424a8cc957f
--- /dev/null
+++ b/dev-util/goland/Manifest
@@ -0,0 +1,3 @@
+DIST goland-173.3531.21.tar.gz 213040527 SHA256 5738129cb5ab81428cf6fa0ec18e97221b1303d966e679e575a0ac8e669170cd SHA512 db2deb4e52fb4135e3fb27c63a181c34acddf61dd2bedf81e50144a85b3e9bcb1a7490532b6841815e2b888c660aa26bc8c3176f83bb30bcf20ec568cdfeb65b WHIRLPOOL 51502c1d35a582601378a6ed403c4c84d36418a340f00479180143a1eddcae05832242f9bb075ebb63c906c5f0385a5ef53a32b4d2975669a8b54266b9778e8c
+EBUILD goland-173.3531.21.ebuild 1040 SHA256 1b465b0ac140a4a11f9a702bfca9de927bcec78cc4250c212ba00e07ec28fb8f SHA512 ba6903ab409c8e4d9023708cb5f16b6304e59cae302270e1055a906bcab52e778c9923265d53aa97c0118ea00d667f39baaaa2ed7840fdda8f26f785313d9e97 WHIRLPOOL 0382040b962041a64e5b6703b3412d63c7152ee0b0c68b7711c46cf8ec32bef3309364115ef6cf4cf13b44cd40f71b82241b194653c680025ce29099f643814f
+MISC metadata.xml 245 SHA256 6fedd876236c2f1fe2687e73628381650ebecef9734f88f6d483bec5bf475a7f SHA512 ce14e948c06d19eefb8504b77746e191099fd4d66083ad01ac62d874029b397af4edc5940312dac09c9ed18ccbcd98909b93fc0bc463c15db97bf68d13c9fec4 WHIRLPOOL 4957affde63b54e118270c40ce12683872777b41ec1a798f7b03807a99917148279d392f71cbcf95ec4e5d586ee5fc0400aea77d9e46083873a441a4907ba13d
diff --git a/dev-util/goland/goland-173.3531.21.ebuild b/dev-util/goland/goland-173.3531.21.ebuild
new file mode 100644
index 000000000000..3698daaba68c
--- /dev/null
+++ b/dev-util/goland/goland-173.3531.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+SLOT=0
+
+SRC_URI="http://download.jetbrains.com/go/${P}.tar.gz"
+DESCRIPTION="Golang IDE by JetBrains"
+HOMEPAGE="http://www.jetbrains.com/go"
+
+KEYWORDS="~amd64"
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+
+QA_PREBUILT="opt/${P}/*"
+
+S=${WORKDIR}/GoLand-${PV}
+
+RDEPEND="dev-lang/go"
+
+src_prepare() {
+ default
+ if ! use arm; then
+ rm -rf bin/fsnotifier-arm || die
+ fi
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{${PN}.sh,fsnotifier{,64}}
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "gogland" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+}
diff --git a/dev-util/goland/metadata.xml b/dev-util/goland/metadata.xml
new file mode 100644
index 000000000000..97df2a00971b
--- /dev/null
+++ b/dev-util/goland/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+</pkgmetadata>