summaryrefslogtreecommitdiff
path: root/dev-util/gource/gource-0.51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-util/gource/gource-0.51.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-util/gource/gource-0.51.ebuild')
-rw-r--r--dev-util/gource/gource-0.51.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/gource/gource-0.51.ebuild b/dev-util/gource/gource-0.51.ebuild
new file mode 100644
index 000000000000..a1e9aa52d6f9
--- /dev/null
+++ b/dev-util/gource/gource-0.51.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="https://gource.io/"
+SRC_URI="https://github.com/acaudwell/Gource/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.46:=[threads(+)]
+ >=media-libs/glew-1.5:0=
+ >=media-libs/libpng-1.2:0=
+ media-libs/libsdl2[video,opengl,X]
+ media-libs/sdl2-image[jpeg,png]
+ dev-libs/libpcre:3
+ dev-libs/tinyxml
+ media-libs/freetype:2
+ media-libs/mesa[X(+)]
+ virtual/glu:0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/freefont
+"
+DEPEND="${COMMON_DEPEND}
+ >=media-libs/glm-0.9.3
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README ChangeLog THANKS )
+
+src_configure() {
+ # fix bug #386525
+ # this enables gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cppflags -DTIXML_USE_STL;
+ fi
+
+ econf \
+ --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
+ --with-tinyxml
+}