summaryrefslogtreecommitdiff
path: root/dev-util/gperf/gperf-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/gperf/gperf-3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/gperf/gperf-3.1.ebuild')
-rw-r--r--dev-util/gperf/gperf-3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/gperf/gperf-3.1.ebuild b/dev-util/gperf/gperf-3.1.ebuild
new file mode 100644
index 000000000000..3553aebc5a5d
--- /dev/null
+++ b/dev-util/gperf/gperf-3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A perfect hash function generator"
+HOMEPAGE="https://www.gnu.org/software/gperf/"
+SRC_URI="mirror://gnu/gperf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "/^CPPFLAGS /s:=:+=:" \
+ */Makefile.in || die #444078
+
+ eapply_user
+}
+
+src_configure() {
+ econf --htmldir='$(datarootdir)/doc/'"${PF}/html"
+}