summaryrefslogtreecommitdiff
path: root/dev-util/heaptrack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-util/heaptrack
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-util/heaptrack')
-rw-r--r--dev-util/heaptrack/Manifest3
-rw-r--r--dev-util/heaptrack/files/heaptrack-1.3.0-cmake.patch58
-rw-r--r--dev-util/heaptrack/heaptrack-1.3.0.ebuild75
3 files changed, 136 insertions, 0 deletions
diff --git a/dev-util/heaptrack/Manifest b/dev-util/heaptrack/Manifest
index 73e2b503078e..81e826740efe 100644
--- a/dev-util/heaptrack/Manifest
+++ b/dev-util/heaptrack/Manifest
@@ -1,2 +1,5 @@
+AUX heaptrack-1.3.0-cmake.patch 2070 BLAKE2B 9e84e46f1d10507e337323a18418b248edae02375a2f3184331dc638e57688b78ef84bcf88ef3c7f239b3bd4225950cb99a611bc8fb124b5af2478d58eb892bc SHA512 3786d8edb7485710ef2255ce2a82bf82f23734989fac67ec2cdb77a821dc33e00415a2d398b25a12505922bbf3e575b885007c125ff7f2c1881cdf1de5ca216f
+DIST heaptrack-1.3.0.tar.xz 5521900 BLAKE2B b633ff53d83bd001705a93e2d9ffec1a994a3860cc2154334deda24c7b9d015d233e09e091201351cd3f885668a97d51eafc3b63604996c3a47ed3fdc87446da SHA512 803cc41cbd22090f3478b92097119d03a47ace8d81dc1f30490bea8f9460ae4b9fb7c9d5f64818961c8e118eafce486bea2b6765e5f2a81c91eef5690b1246de
+EBUILD heaptrack-1.3.0.ebuild 1511 BLAKE2B deb70de58ae22d6bc166b1176527d457854ca216c6401316414664b2430dbbe11f35c2f8065d99e89513d125f886949ad67c6e2a0166df39ca66c6931a4aef63 SHA512 d65ac0726600810fdf88b7c02791e107df2f5d3d5a2353acf6d510760476aad7efca7f2e2110e5a55ded57a8321e4dce09f25da80a3c81d9f0939cbe3c3516be
EBUILD heaptrack-9999.ebuild 1394 BLAKE2B 4fdc890f870682587d82934bf1971f65b0dc1b866435bf4b9d270790522259a0e4782e26f996c40eda40c039c5101543cc9ac5fcec52edeb27cd0e330ba4ead8 SHA512 b7ed8b66849601b1dd04129dac0bfd40a40355c2fcf553c7d915bccd9c098de1ec54025acb88f744962720f6c88a1f8433d0d6127a0dd548692f08057211fc64
MISC metadata.xml 395 BLAKE2B bfbf8422aff66acc6dc7097c261cfc2d967b62bf7a88516e9c433b5702fe4dcbc81928986abd87eab7cc8ce3201f728bd5482eddc6635cef0c83456c52a8137e SHA512 3713423aa87a37024dbd9b0582a8fc43b8b731b0ecb8013534562151ea982e156361f7a95d1efc3e1ec31b6ee1fd659686d6214fbc64e07c09c3ed76fa7f19ab
diff --git a/dev-util/heaptrack/files/heaptrack-1.3.0-cmake.patch b/dev-util/heaptrack/files/heaptrack-1.3.0-cmake.patch
new file mode 100644
index 000000000000..fe4cfd6fed93
--- /dev/null
+++ b/dev-util/heaptrack/files/heaptrack-1.3.0-cmake.patch
@@ -0,0 +1,58 @@
+From 24d593624a41488416116057fc36e9962a548477 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 20 Dec 2021 11:43:26 +0100
+Subject: [PATCH] Let releaseme know to skip po install
+
+Since KF5I18n is optional AND dependent on HEAPTRACK_BUILD_GUI, we
+have to call ki18n_install(po) conditionally on our own and in
+addition tell releaseme not to touch CMakeLists.txt to do the same.
+
+Otherwise releaseme adds the following code unconditionally at the
+end of the file:
+
+ find_package(KF5I18n CONFIG REQUIRED)
+ ki18n_install(po)
+
+ki18n_install checks for existence of po subdir and returns silently
+if none found, so it is safe for git sources too.
+
+* asturmlechner 2021-12-20: Modified for 1.3.0 release.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 4 ++++
+ src/analyze/CMakeLists.txt | 3 +++
+ 2 files changed, 7 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ccfc88..06c43cf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -169,7 +169,8 @@
+ add_subdirectory(src)
+ add_subdirectory(tests)
+
+-feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
++# Let releaseme know about this:
++# SKIP_PO_INSTALL
++# (KF5I18n is optional in src/analyze/CMakeLists.txt...)
+
+-find_package(KF5I18n CONFIG REQUIRED)
+-ki18n_install(po)
++feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+diff --git a/src/analyze/CMakeLists.txt b/src/analyze/CMakeLists.txt
+index 592f337..763c671 100644
+--- a/src/analyze/CMakeLists.txt
++++ b/src/analyze/CMakeLists.txt
+@@ -41,6 +41,9 @@ if(HEAPTRACK_BUILD_GUI)
+ find_package(KF5 ${REQUIRED_IN_APPIMAGE} COMPONENTS CoreAddons I18n ItemModels ThreadWeaver ConfigWidgets KIO IconThemes)
+ find_package(KChart ${REQUIRED_IN_APPIMAGE} "2.6.0")
+ set_package_properties(KChart PROPERTIES TYPE RECOMMENDED PURPOSE "Required for the heaptrack_gui executable. Get it from the kdiagram module.")
++ if(KF5I18n_FOUND)
++ ki18n_install(../../po)
++ endif()
+ endif()
+ endif()
+
+--
+2.34.1
diff --git a/dev-util/heaptrack/heaptrack-1.3.0.ebuild b/dev-util/heaptrack/heaptrack-1.3.0.ebuild
new file mode 100644
index 000000000000..bca3728eeba1
--- /dev/null
+++ b/dev-util/heaptrack/heaptrack-1.3.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop kde.org xdg-utils
+
+DESCRIPTION="Fast heap memory profiler"
+HOMEPAGE="https://apps.kde.org/heaptrack/
+https://milianw.de/blog/heaptrack-a-heap-memory-profiler-for-linux"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui test zstd"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=[zstd?]
+ sys-libs/libunwind:=
+ sys-libs/zlib
+ gui? (
+ dev-libs/kdiagram:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kconfig:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kitemmodels:5
+ kde-frameworks/kwidgetsaddons:5
+ kde-frameworks/threadweaver:5
+ )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}
+ gui? ( >=kde-frameworks/kf-env-4 )
+"
+BDEPEND="
+ gui? ( kde-frameworks/extra-cmake-modules:5 )
+"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) # bug 829606
+
+src_prepare() {
+ cmake_src_prepare
+ rm -rf 3rdparty/boost-zstd || die # ensure no bundling
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHEAPTRACK_BUILD_GUI=$(usex gui)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zstd ZSTD)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}