summaryrefslogtreecommitdiff
path: root/dev-util/hip/hip-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-06 12:54:39 +0000
commit56330f065f2b903d9e1b2dffc63719fef5897a45 (patch)
tree659a7ebca7cb9f7504b018c1484df84ba4f9ab01 /dev-util/hip/hip-6.0.0.ebuild
parent1774f0a748546cbd792bf1eb44757b63be2e0114 (diff)
gentoo auto-resync : 06:01:2024 - 12:54:38
Diffstat (limited to 'dev-util/hip/hip-6.0.0.ebuild')
-rw-r--r--dev-util/hip/hip-6.0.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/hip/hip-6.0.0.ebuild b/dev-util/hip/hip-6.0.0.ebuild
index 9f8f62ca11ad..a2bd451fae26 100644
--- a/dev-util/hip/hip-6.0.0.ebuild
+++ b/dev-util/hip/hip-6.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ DOCS_BUILDER="doxygen"
DOCS_DEPEND="media-gfx/graphviz"
ROCM_SKIP_GLOBALS=1
-inherit cmake docs llvm rocm
+inherit cmake docs flag-o-matic llvm rocm
LLVM_MAX_SLOT=17
@@ -81,6 +81,10 @@ src_prepare() {
src_configure() {
use debug && CMAKE_BUILD_TYPE="Debug"
+ # Fix ld.lld linker error: https://github.com/ROCm/HIP/issues/3382
+ # See also: https://github.com/gentoo/gentoo/pull/29097
+ append-ldflags $(tc-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DCMAKE_PREFIX_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
-DCMAKE_BUILD_TYPE=${buildtype}