summaryrefslogtreecommitdiff
path: root/dev-util/hipcc/hipcc-5.7.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 17:06:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 17:06:50 +0000
commit5a31d854eec302fd1efb1466af757e520ae4e1dc (patch)
tree58a9a7036a479519c2b853ff7646e69d1c6a2339 /dev-util/hipcc/hipcc-5.7.1-r3.ebuild
parent8c58ead574346296889d58006e1bf184da00be3a (diff)
gentoo auto-resync : 19:11:2023 - 17:06:49
Diffstat (limited to 'dev-util/hipcc/hipcc-5.7.1-r3.ebuild')
-rw-r--r--dev-util/hipcc/hipcc-5.7.1-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/hipcc/hipcc-5.7.1-r3.ebuild b/dev-util/hipcc/hipcc-5.7.1-r3.ebuild
new file mode 100644
index 000000000000..90e3186ba999
--- /dev/null
+++ b/dev-util/hipcc/hipcc-5.7.1-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake llvm
+
+LLVM_MAX_SLOT=17
+
+DESCRIPTION="Radeon Open Compute hipcc"
+HOMEPAGE="https://github.com/ROCm-Developer-Tools/hipcc"
+
+KEYWORDS="~amd64"
+SRC_URI="https://github.com/ROCm-Developer-Tools/hipcc/archive/refs/tags/rocm-${PV}.tar.gz -> hipcc-${PV}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/HIPCC-rocm-${PV}
+
+DEPEND="<sys-devel/llvm-18:=
+ <sys-devel/clang-18:=
+ "
+RDEPEND="${DEPEND}
+ !<dev-util/hip-5.7"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.7.1-fno-stack-protector.patch"
+ "${FILESDIR}/${PN}-5.7.1-hipcc-hip-version.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "s:\$ROCM_PATH/llvm/bin:$(get_llvm_prefix ${LLVM_MAX_SLOT})/bin:" \
+ -i bin/hipvars.pm || die
+
+ sed -e "s:\$ENV{'DEVICE_LIB_PATH'}:'${EPREFIX}/usr/lib/amdgcn/bitcode':" \
+ -e "s:\$ENV{'HIP_LIB_PATH'}:'${EPREFIX}/usr/$(get_libdir)':" \
+ -e "/HIP.*FLAGS.*isystem.*HIP_INCLUDE_PATH/d" \
+ -i bin/hipcc.pl || die
+}
+
+src_install() {
+ cmake_src_install
+ # rm unwanted copy
+ rm -rf "${ED}/usr/hip" || die
+}