summaryrefslogtreecommitdiff
path: root/dev-util/howdoi/howdoi-2.0.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-util/howdoi/howdoi-2.0.15.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-util/howdoi/howdoi-2.0.15.ebuild')
-rw-r--r--dev-util/howdoi/howdoi-2.0.15.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/howdoi/howdoi-2.0.15.ebuild b/dev-util/howdoi/howdoi-2.0.15.ebuild
new file mode 100644
index 000000000000..8fba32c5aa56
--- /dev/null
+++ b/dev-util/howdoi/howdoi-2.0.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="manual"
+PYTHON_COMPAT=( python{3_7,3_8} )
+inherit distutils-r1
+
+DESCRIPTION="A code search tool"
+HOMEPAGE="https://pypi.org/project/howdoi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cachelib[${PYTHON_USEDEP}]
+ dev-python/keep[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyquery-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+"