summaryrefslogtreecommitdiff
path: root/dev-util/hxtools/hxtools-20180301.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /dev-util/hxtools/hxtools-20180301.ebuild
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'dev-util/hxtools/hxtools-20180301.ebuild')
-rw-r--r--dev-util/hxtools/hxtools-20180301.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/hxtools/hxtools-20180301.ebuild b/dev-util/hxtools/hxtools-20180301.ebuild
new file mode 100644
index 000000000000..38fb9a949d55
--- /dev/null
+++ b/dev-util/hxtools/hxtools-20180301.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of tools and scripts"
+HOMEPAGE="http://inai.de/projects/hxtools/"
+SRC_URI="http://jftp.inai.de/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ >=sys-apps/util-linux-2.19
+ sys-libs/libcap
+ >=sys-libs/libhx-3.12.1
+ >=sys-apps/pciutils-3
+ x11-libs/libxcb:0=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+
+ # man2html is provided by man
+ rm -rf "${ED}"/usr/bin/man2html
+ rm -rf "${ED}"/usr/share/man/man1/man2html*
+
+ # Don't collide with dev-util/cwdiff
+ mv "${ED}"/usr/bin/cwdiff "${ED}"/usr/bin/cwdiff.hx || die
+ mv "${ED}"/usr/share/man/man1/cwdiff.1 "${ED}"/usr/share/man/man1/cwdiff.hx.1 || die
+}