summaryrefslogtreecommitdiff
path: root/dev-util/idea-community
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-18 05:38:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-18 05:38:53 +0000
commit3e4b97f04e1561890eb4b0bcb3a411b931c08d02 (patch)
treed34aa692c74eb0e0de725fa00b6df5785268b52c /dev-util/idea-community
parent78fce155315439a69aa67573fd4696b735649431 (diff)
gentoo auto-resync : 18:02:2024 - 05:38:53
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest3
-rw-r--r--dev-util/idea-community/idea-community-2023.3.4-r1.ebuild134
2 files changed, 137 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 4d171f611b4b..706ad0c2b8bc 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,3 +1,6 @@
+DIST idea-community-2023.3.4-aarch64.tar.gz 817123037 BLAKE2B 08cca91d5cad34a292e79668c1096b344f52305700c82a93b33e5fb8182ec4708ccb62e74908a7a8ef6b36c1b41edc415b90c109039afc1840b257c605aff62e SHA512 ad33277002e818ac4dc751da19f428ccc4aedcf08c04bbb483d2e2a5c5d4704d1d4c111fb33d88593601c9aaefa25fb3c0cffec439be0e9909c09cec7579566d
+DIST idea-community-2023.3.4-amd64.tar.gz 815935882 BLAKE2B 9ecd52dc1d00b5c733acd798b093ed2544d73368ba3016baaa3e360e4a4f714c6f7b39cc0a4da814fe7d8b8d83af10e633eb8fad26cd615d67423483f699fa0f SHA512 048a25e184be4a4739bc788050f2887a76cadcafc2d6033eed2d8ebaf5c71116140e9cd30b9cae24f244b50296a46effd83c099f897f79b1df74ec2995899602
DIST idea-community-2023.3.4.tar.gz 815935882 BLAKE2B 9ecd52dc1d00b5c733acd798b093ed2544d73368ba3016baaa3e360e4a4f714c6f7b39cc0a4da814fe7d8b8d83af10e633eb8fad26cd615d67423483f699fa0f SHA512 048a25e184be4a4739bc788050f2887a76cadcafc2d6033eed2d8ebaf5c71116140e9cd30b9cae24f244b50296a46effd83c099f897f79b1df74ec2995899602
+EBUILD idea-community-2023.3.4-r1.ebuild 3784 BLAKE2B 09178e7c5fa82c6ce458000db1ad77048d18498d284c18a119dcb780855d16d66ea217487d8c182c60e29d9e36cdfed76beadfb5f0b0140f93839d47146f3005 SHA512 bec8d5e7c15d3dc76bc702718612c2bd99e3c2ee1dd3df21b9e78d4ddcd7b2b193e3beac95e083255b88f4de487ab2fbbd4473667b879a4ca8184f8e808e9801
EBUILD idea-community-2023.3.4.ebuild 3587 BLAKE2B 5a297b548cb1a37b00d52333596af9c292262c5b3aac3089bd3701ec1bef9cfafc8a4744659169fc99edb781e9797d416ed18416f2392398531bfa559a811a54 SHA512 5edf46dba30c7fc9b5cb79380bc3b304d49cd46dc5933157fafac33576f47727774ad0593e63f7cc7fdf0976e55a13746b3d7fd85018d2de775e5e77a29d11ff
MISC metadata.xml 454 BLAKE2B 297cfd8c543bf216cd45b66b5284f310659422e91f12af3d0bbe2ff689d94c96988d4c125c75a95526135b2c0f54a004ee43e1c1c4dfe4d1d68e86af5f75ab0d SHA512 5ca382bcbc51ea5400cbaeb067bccfcb4a245e208a2769d800cbd80fc7151310f895d410e5828c9a32223ab93345716ba4a2ebce521092631a4b7c0858519ef2
diff --git a/dev-util/idea-community/idea-community-2023.3.4-r1.ebuild b/dev-util/idea-community/idea-community-2023.3.4-r1.ebuild
new file mode 100644
index 000000000000..6dccef36ed45
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2023.3.4-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+SRC_URI="
+ amd64? ( https://download.jetbrains.com/idea/ideaIC-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( https://download.jetbrains.com/idea/ideaIC-${PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
+ "
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.8.1_p1:17
+ >=dev-java/openjdk-bin-17.0.8.1_p1:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ dev-libs/libdbusmenu"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+S="${WORKDIR}/idea-IC-${PV}"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+ else
+ JRE_DIR=jre
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restarter,fsnotifier}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+
+ # remove bundled java
+ rm -r ${dst}/jbr || die "Unable to remove bundled java"
+
+}