summaryrefslogtreecommitdiff
path: root/dev-util/imediff2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-util/imediff2
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/imediff2')
-rw-r--r--dev-util/imediff2/Manifest4
-rw-r--r--dev-util/imediff2/files/1.1.2-python-3.patch155
-rw-r--r--dev-util/imediff2/imediff2-1.1.2-r5.ebuild39
-rw-r--r--dev-util/imediff2/metadata.xml12
4 files changed, 0 insertions, 210 deletions
diff --git a/dev-util/imediff2/Manifest b/dev-util/imediff2/Manifest
deleted file mode 100644
index 3a4b6e3e07f7..000000000000
--- a/dev-util/imediff2/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX 1.1.2-python-3.patch 4553 BLAKE2B bc16393f3c7071017255e8f188456e77d89a2ab2d605d6d99882aef4c65c7e5270a9348cf278a98d5ff7527423e899feffbb93b00f12a8c6e9a7b131acb86eba SHA512 fa5065572eb7fdbf38e3d7785ae92bddaeae8eadd9dbd006f5691c8647087df7529015750b66ea7618dd3306fcda80083c8dc2d2f019787137095db5b2c1a4d7
-DIST imediff2_1.1.2.orig.tar.gz 17974 BLAKE2B f83b6ab652b1dd044587e75e4e7551a8132e1860b14f0d85d37f35383bd161a672860162e93554cf4db844d6a4700fa1876a30874c50fcb8442b4190a9b19185 SHA512 54d196d67107283bc3339eba30acb1c60972f256a268e86da397e0bdafa05220facc7979638a6a917b0c2dc7171edc3aa6b188295c9f40e9debf87a63731e748
-EBUILD imediff2-1.1.2-r5.ebuild 814 BLAKE2B 95c325c3a197088b415fa739553a7e0be0fd60389f4f0e2b3af82caa097adfdd3b4e751b5393282cdf2422353463d546a6d6623fe165175c9f39ab73a952afa3 SHA512 6cd0c1a6014f058ed575f5492c593b97b2472294b71e558a210601f293172a1d5a323b6b9917d93a7504d668c57a568d02454f9dee6e01cdff465026c5b7b819
-MISC metadata.xml 357 BLAKE2B fd7b99a53b06a9ed310039486dd9c631d70ae5af05b47b42009e92b6134e52ee13e520066b8170f70b000a8eca1ca6c3c670478e393a4e36f3fe6c21187f090e SHA512 2c36e9355ac79bb027b25c63e0487299cfdf226217ea891349c4665107f6e7fb2931e56386ff1d88f16ad9e573041fc94658f61e8658d234b04bfa49c5fe902b
diff --git a/dev-util/imediff2/files/1.1.2-python-3.patch b/dev-util/imediff2/files/1.1.2-python-3.patch
deleted file mode 100644
index 811f41583129..000000000000
--- a/dev-util/imediff2/files/1.1.2-python-3.patch
+++ /dev/null
@@ -1,155 +0,0 @@
---- a/imediff2 2017-11-14 09:28:57.007929569 -0500
-+++ b/imediff2 2017-11-14 10:11:12.618496692 -0500
-@@ -18,20 +18,20 @@
- # License along with the program; if not, write to the Free Software
- # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-
--VERSION = '1.1.1'
-+VERSION = '1.1.2'
- PACKAGE = 'imediff2'
-
--import curses.wrapper
-+import sys
-+if sys.version_info<(3,0,0):
-+ import curses.wrapper
- import curses
- import tempfile
- import gettext
- import difflib
- import getopt
--import string
- import types
- import time
- import pty
--import sys
- import os
- import errno
-
-@@ -121,19 +122,19 @@
- def read_lines( filename ):
- global assume_empty
- try:
-- fp = file( filename )
-+ fp = open( filename )
- l = fp.readlines()
- fp.close()
- return l
-- except IOError, (error, message):
-- if error == errno.ENOENT and assume_empty:
-+ except IOError as e:
-+ if e.errno == errno.ENOENT and assume_empty:
- return ""
- else:
-- sys.stderr.write(_("Could not read '%s': %s\n") % (filename, message))
-+ sys.stderr.write(_("Could not read '%s': %s\n") % (filename, e.strerror))
- sys.exit(3)
-
- def strip_end_lines( txt ):
-- return string.replace(string.replace(txt,"%c"%10,""),"%c"%13,"")
-+ return txt.replace("%c"%10,"").replace("%c"%13,"")
-
- def main(stdscr, lines_a, lines_b, start_mode):
- global sel, active_chunks, x,y, lines, textpad, contw,conth
-@@ -237,7 +238,7 @@
- active_chunks.append( [j, j+len(line_list), i] )
-
- for l in line_list:
-- lines.append( [string.expandtabs(strip_end_lines(l)),
-+ lines.append( [strip_end_lines(l).expandtabs(),
- decor, color_pair] )
- j+=1
-
-@@ -287,9 +287,9 @@
- def sel_next( dir ):
- global sel, active_chunks
- if dir == 'up':
-- rng = range(sel-1, -1, -1)
-+ rng = list(range(sel-1, -1, -1))
- else:
-- rng = range(sel+1, len(active_chunks))
-+ rng = list(range(sel+1, len(active_chunks)))
- for j in rng:
- if active_chunks[j][1] > y and active_chunks[j][0] < y+winh:
- sel = j
-@@ -442,7 +441,7 @@
- elif c == ord('h') or c == ord('?') or c == curses.KEY_HELP:
- helpw = 0
- helph = 0
-- for l in string.split(helptext(), "%c"%10):
-+ for l in helptext().split("%c"%10):
- helpw = max(helpw, len(l))
- helph += 1
- helppad = curses.newpad(helph+2, helpw+2)
-@@ -512,21 +513,21 @@
- try:
- opts, args = getopt.getopt(sys.argv[1:], "hmuo:abcNV",
- ["help","mono","unresolved","output=", "version", "new-file"])
--except getopt.GetoptError, e:
-- print _("Error: ") + str(e)
-- print usagetext()
-+except getopt.GetoptError as e:
-+ print((_("Error: ") + str(e)))
-+ print((usagetext()))
- sys.exit(2)
-
- for o, a in opts:
- if o in ("-h", "--help"):
-- print usagetext()
-+ print((usagetext()))
- sys.exit()
- elif o in ("-V", "--version"):
-- print "%s %s" % (PACKAGE, VERSION)
-+ print(("%s %s" % (PACKAGE, VERSION)))
- sys.exit()
-
- if len(args)<2:
-- print usagetext()
-+ print((usagetext()))
- sys.exit(2)
-
- for o, a in opts:
-@@ -592,15 +592,15 @@
- if launch_editor:
- assert( not editor is None )
- try:
- (of, of_name) = tempfile.mkstemp(prefix='imediff2')
-- os.write( of, output )
-+ os.write( of, output.encode() )
- os.close(of)
- time.sleep(0.1) # make the change visible - many editor look a lot like imediff2
- editor_ret = os.system('%s %s' % (editor, of_name))
- time.sleep(0.1)
- if editor_ret == 0:
- new_b_lines = read_lines(of_name)
-- if string.join(new_b_lines, '') == output:
-+ if ''.join(new_b_lines) == output:
- chunk_mode = 'old'
- elif new_b_lines != lines_a:
- lines_b = new_b_lines
-@@ -607,8 +608,8 @@
- else:
- chunks = 'old'
- os.unlink(of_name)
-- except IOError, (error, message):
-- sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, message));
-+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, e.strerror));
-
- if not launch_editor:
- break
-@@ -619,11 +620,11 @@
- else:
- try:
- if ofile is not None:
-- of = file(ofile, 'wb')
-+ of = open(ofile, 'wb')
-- of.write( output )
-+ of.write( output.encode() )
- of.close()
- sys.exit(0)
-- except IOError, (error, message):
-- sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, message));
-+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, e.strerror));
-
- sys.exit(3)
diff --git a/dev-util/imediff2/imediff2-1.1.2-r5.ebuild b/dev-util/imediff2/imediff2-1.1.2-r5.ebuild
deleted file mode 100644
index 22d3fb364d12..000000000000
--- a/dev-util/imediff2/imediff2-1.1.2-r5.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
-PYTHON_REQ_USE="ncurses"
-
-inherit python-single-r1 versionator
-
-MY_P=${PN}_$(replace_version_separator 3 -)
-
-DESCRIPTION="An interactive, user friendly 2-way merge tool in text mode"
-HOMEPAGE="https://elonen.iki.fi/code/imediff/"
-SRC_URI="mirror://debian/pool/main/i/${PN}/${MY_P}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S=${WORKDIR}/${PN}
-
-PATCHES=( "${FILESDIR}/${PV}-python-3.patch" )
-
-src_compile() {
- # Otherwise the docs get regenerated :)
- :
-}
-
-src_install() {
- python_doscript imediff2
- dodoc AUTHORS README
- doman imediff2.1
-}
diff --git a/dev-util/imediff2/metadata.xml b/dev-util/imediff2/metadata.xml
deleted file mode 100644
index b01015a7e56c..000000000000
--- a/dev-util/imediff2/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>dev-zero@gentoo.org</email>
- <name>Tiziano Müller</name>
- </maintainer>
- <maintainer type="person">
- <email>grknight@gentoo.org</email>
- <name>Brian Evans</name>
- </maintainer>
-</pkgmetadata>