summaryrefslogtreecommitdiff
path: root/dev-util/imediff2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-17 06:41:55 +0000
commit6d730aa8064fbab6cc54447b6ed0e60b99c13256 (patch)
tree8c303cb48dc49dd218b79708ca71904653c5f831 /dev-util/imediff2
parentcb2f73d10494730ba590096a1f24ebc6d0d61a9f (diff)
gentoo auto-resync : 17:01:2025 - 06:41:55
Diffstat (limited to 'dev-util/imediff2')
-rw-r--r--dev-util/imediff2/Manifest4
-rw-r--r--dev-util/imediff2/files/1.1.2.1-python-3.patch157
-rw-r--r--dev-util/imediff2/imediff2-1.1.2.1.ebuild39
-rw-r--r--dev-util/imediff2/metadata.xml9
4 files changed, 0 insertions, 209 deletions
diff --git a/dev-util/imediff2/Manifest b/dev-util/imediff2/Manifest
deleted file mode 100644
index 27f22e9a5b33..000000000000
--- a/dev-util/imediff2/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX 1.1.2.1-python-3.patch 5273 BLAKE2B cb2be2f11021d61f998d228d26cfad956ec3c6d18aeafb7ece82d5f3de1e624776033746a51542b601d3ab94db2d57aece68315f772d8299f22b2010d2151905 SHA512 212cb76362c8243824d16f514a2dafc0c746467454c463e34f1840022d4a988874878e544ee944726947a287e5db27a78d2b99b790a78f4188d10ed9e2eaaea5
-DIST imediff2_1.1.2.1.orig.tar.gz 20393 BLAKE2B 560eef8600bac8ad302907563bd8520ef7881009c8a35c74427d0d5d9e8d4303446f1eb39c01fec201c798f286023765776a84b1e1aaa9e2d585a45870375f16 SHA512 ad0e22f5f2f16efb976a0d6d16c34798cc8aace4251a99cb7764df6841f93c2a6bb9dc8cbb59d8f3ae5a5ad7c161a05b9c3c7b36cc7bdf98eac3ef3b735ef6c4
-EBUILD imediff2-1.1.2.1.ebuild 795 BLAKE2B f140ecd37f079aba6dd47f3278610d7d3d8014ef48fdce46840d5c6412424ca9f88183cf4b471eeac7809a074bc961d56ece8c2c92d73dfe91fb46c0b24a6338 SHA512 1a7fab32bc28e5c8ffbdef716024fb9e9e6b5238e11c6cc763f871e38e0e4fd5cc353e1adb844fa4d367c801435337aa454fce44e047600d794fcb3b213c75e5
-MISC metadata.xml 274 BLAKE2B c12371b16b18c652b34dd07d73ec99c13ec413416e1ad91a88e560b5cda4e85a97f452e023c13a1a91e96d2741cbcd991c8ddd2a29686c7f6ac71a7ca4f5d6c8 SHA512 6d56009523ef3daf8e21c25045f97cc821852d12ae3ce220d9b51b61bedc37130ddfb20355b54101762af349d3c5fd383624300e1fa511840441427fd17075ae
diff --git a/dev-util/imediff2/files/1.1.2.1-python-3.patch b/dev-util/imediff2/files/1.1.2.1-python-3.patch
deleted file mode 100644
index aa26ad7f9dbb..000000000000
--- a/dev-util/imediff2/files/1.1.2.1-python-3.patch
+++ /dev/null
@@ -1,157 +0,0 @@
-diff -aurN a/imediff2 b/imediff2
---- a/imediff2 2018-10-20 13:36:19.000000000 -0400
-+++ b/imediff2 2021-03-03 10:03:31.121774492 -0500
-@@ -167,19 +167,19 @@
- def read_lines( filename ):
- global assume_empty
- try:
-- fp = file( filename )
-+ fp = open( filename )
- l = fp.readlines()
- fp.close()
- return l
-- except IOError, (error, message):
-- if error == errno.ENOENT and assume_empty:
-+ except IOError as e:
-+ if e.errno == errno.ENOENT and assume_empty:
- return ""
- else:
-- sys.stderr.write(_("Could not read '%s': %s\n") % (filename, message))
-+ sys.stderr.write(_("Could not read '%s': %s\n") % (filename, e.strerror))
- sys.exit(3)
-
- def strip_end_lines( txt ):
-- return string.replace(string.replace(txt,"%c"%10,""),"%c"%13,"")
-+ return txt.replace("%c"%10,"").replace("%c"%13,"")
-
- def main(stdscr, lines_a, lines_b, start_mode):
- global sel, active_chunks, x,y, lines, textpad, contw,conth
-@@ -283,7 +283,7 @@
- active_chunks.append( [j, j+len(line_list), i] )
-
- for l in line_list:
-- lines.append( [string.expandtabs(strip_end_lines(l)),
-+ lines.append( [strip_end_lines(l).expandtabs(),
- decor, color_pair] )
- j+=1
-
-@@ -332,9 +332,9 @@
- def sel_next( dir ):
- global sel, active_chunks
- if dir == 'up':
-- rng = range(sel-1, -1, -1)
-+ rng = list(range(sel-1, -1, -1))
- else:
-- rng = range(sel+1, len(active_chunks))
-+ rng = list(range(sel+1, len(active_chunks)))
- for j in rng:
- if active_chunks[j][1] > y and active_chunks[j][0] < y+winh:
- sel = j
-@@ -487,7 +487,7 @@
- elif c == ord('h') or c == ord('?') or c == curses.KEY_HELP:
- helpw = 0
- helph = 0
-- for l in string.split(helptext(), "%c"%10):
-+ for l in helptext().split("%c"%10):
- helpw = max(helpw, len(l))
- helph += 1
- helppad = curses.newpad(helph+2, helpw+2)
-@@ -502,7 +502,7 @@
- elif c == ord('q') or c == curses.KEY_CANCEL:
- quitw = 0
- quith = 0
-- for l in string.split(quittext(), "%c"%10):
-+ for l in quittext().split("%c"%10):
- quitw = max(quitw, len(l))
- quith += 1
- quitpad = curses.newpad(quith+2, quitw+2)
-@@ -571,33 +571,33 @@
- try:
- opts, args = getopt.getopt(sys.argv[1:], "hmuo:abcNtV",
- ["help","mono","unresolved","output=", "template", "version", "new-file"])
--except getopt.GetoptError, e:
-- print _("Error: ") + str(e)
-- print usagetext()
-+except getopt.GetoptError as e:
-+ print((_("Error: ") + str(e)))
-+ print(usagetext())
- sys.exit(2)
-
- for o, a in opts:
- if o in ("-h", "--help"):
-- print usagetext()
-+ print((usagetext()))
- sys.exit()
- elif o in ("-t", "--template"):
- try:
- with open(config_file, 'w') as f:
-- print >>f, "# Configuration for imediff2: (Erase this file to reset)"
-- print >>f, "# <command_key_in_action> <command_key_in_manpage>"
-- print >>f, "# edit only first character of each line to 'a'...'z'"
-- print >>f, "#"
-+ print(("# Configuration for imediff2: (Erase this file to reset)"), file=f)
-+ print(("# <command_key_in_action> <command_key_in_manpage>"), file=f)
-+ print(("# edit only first character of each line to 'a'...'z'"), file=f)
-+ print(("#"), file=f)
- for k in kcvalues:
-- print >>f, "%s %s" % (k , k)
-+ print(("%s %s" % (k , k)), file=f)
- except:
-- print "%s not writable, aborting" % config_file
-+ print(("%s not writable, aborting" % config_file))
- sys.exit()
- elif o in ("-V", "--version"):
-- print "%s %s" % (PACKAGE, VERSION)
-+ print(("%s %s" % (PACKAGE, VERSION)))
- sys.exit()
-
- if len(args)<2:
-- print usagetext()
-+ print((usagetext()))
- sys.exit(2)
-
- for o, a in opts:
-@@ -692,14 +695,14 @@
- assert( not editor is None )
- try:
- (of, of_name) = tempfile.mkstemp(prefix='imediff2')
-- os.write( of, output )
-+ os.write( of, output.encode() )
- os.close(of)
- time.sleep(0.1) # make the change visible - many editor look a lot like imediff2
- editor_ret = os.system('%s %s' % (editor, of_name))
- time.sleep(0.1)
- if editor_ret == 0:
- new_b_lines = read_lines(of_name)
-- if string.join(new_b_lines, '') == output:
-+ if ''.join(new_b_lines) == output:
- chunk_mode = 'old'
- elif new_b_lines != lines_a:
- lines_b = new_b_lines
-@@ -707,8 +710,8 @@
- else:
- chunks = 'old'
- os.unlink(of_name)
-- except IOError, (error, message):
-- sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, message));
-+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, e.strerror));
-
- if not launch_editor:
- break
-@@ -719,11 +722,11 @@
- else:
- try:
- if ofile is not None:
-- of = file(ofile, 'wb')
-- of.write( output )
-+ of = open(ofile, 'wb')
-+ of.write( output.encode() )
- of.close()
- sys.exit(0)
-- except IOError, (error, message):
-- sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, message));
-+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, e.strerror));
-
- sys.exit(3)
diff --git a/dev-util/imediff2/imediff2-1.1.2.1.ebuild b/dev-util/imediff2/imediff2-1.1.2.1.ebuild
deleted file mode 100644
index e2e1bb5b5818..000000000000
--- a/dev-util/imediff2/imediff2-1.1.2.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="ncurses"
-
-inherit python-single-r1
-
-MY_P="${PN}_${PV}"
-
-DESCRIPTION="An interactive, user friendly 2-way merge tool in text mode"
-HOMEPAGE="https://github.com/osamuaoki/imediff"
-SRC_URI="mirror://debian/pool/main/i/${PN}/${MY_P}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-#S="${WORKDIR}/${PN}"
-
-PATCHES=( "${FILESDIR}/${PV}-python-3.patch" )
-
-src_compile() {
- # Otherwise the docs get regenerated :)
- :
-}
-
-src_install() {
- python_doscript imediff2
- dobin git-ime
- dodoc AUTHORS README.md
- doman imediff2.1 git-ime.1
-}
diff --git a/dev-util/imediff2/metadata.xml b/dev-util/imediff2/metadata.xml
deleted file mode 100644
index c27b2d8278c5..000000000000
--- a/dev-util/imediff2/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">osamuaoki/imediff</remote-id>
- </upstream>
- <stabilize-allarches/>
-</pkgmetadata>