summaryrefslogtreecommitdiff
path: root/dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-11 22:39:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-11 22:39:27 +0100
commitf8399e5cf87087ab3b9f8b1ed2955c0bd5469a9b (patch)
tree1024df3d57721068f6595f3ed2c4732558d5a3ae /dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild
parentf7dbd7518022615cf302931eb062eea56145d71d (diff)
gentoo auto-resync : 11:09:2023 - 22:39:26
Diffstat (limited to 'dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild')
-rw-r--r--dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild b/dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild
new file mode 100644
index 000000000000..45218cd304df
--- /dev/null
+++ b/dev-util/jfrog-cli/jfrog-cli-2.46.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Command line utility for operations on container images and image repositories"
+HOMEPAGE="https://github.com/jfrog/jfrog-cli"
+SRC_URI="https://github.com/jfrog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ build/build.sh jfrog || die
+}
+
+src_install() {
+ dobin jfrog
+ einstalldocs
+}