summaryrefslogtreecommitdiff
path: root/dev-util/lcov/lcov-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-12 12:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-12 12:14:42 +0100
commit3a0e100e02e1c6c2818268f57eae51095cee35af (patch)
treefdc72a395f9087c6e6dfa08b8a1791f65c5af170 /dev-util/lcov/lcov-9999.ebuild
parentb71bf04bdb3f690dbd36fcda860a5a68c1988f6e (diff)
gentoo auto-resync : 12:10:2023 - 12:14:42
Diffstat (limited to 'dev-util/lcov/lcov-9999.ebuild')
-rw-r--r--dev-util/lcov/lcov-9999.ebuild65
1 files changed, 53 insertions, 12 deletions
diff --git a/dev-util/lcov/lcov-9999.ebuild b/dev-util/lcov/lcov-9999.ebuild
index ce1d928ca92f..18570df4f842 100644
--- a/dev-util/lcov/lcov-9999.ebuild
+++ b/dev-util/lcov/lcov-9999.ebuild
@@ -1,29 +1,57 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} == "9999" ]] ; then
+PYTHON_COMPAT=( python3_{10..12} )
+inherit optfeature prefix python-any-r1
+
+DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
+HOMEPAGE="https://github.com/linux-test-project/lcov"
+
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
inherit git-r3
else
- SRC_URI="mirror://sourceforge/ltp/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
+ SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
fi
-inherit optfeature prefix
-
-DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
-HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
-
LICENSE="GPL-2+"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+# Python is used for spreadsheet.py
RDEPEND="
dev-lang/perl
- dev-perl/JSON
+ dev-perl/Capture-Tiny
+ dev-perl/DateTime
+ || (
+ dev-perl/JSON-XS
+ dev-perl/Cpanel-JSON-XS
+ virtual/perl-JSON-PP
+ dev-perl/JSON
+ )
dev-perl/PerlIO-gzip
"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/GD
+ $(python_gen_any_dep '
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/xlsxwriter[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
src_prepare() {
default
@@ -34,10 +62,23 @@ src_prepare() {
src_compile() { :; }
+src_test() {
+ emake -j1 check
+}
+
src_install() {
- emake -j1 PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
+ emake -j1 \
+ PREFIX="${ED}/usr" \
+ CFG_DIR="${ED}/etc" \
+ LCOV_PERL_PATH="${EPREFIX}/usr/bin/perl" \
+ install
}
pkg_postinst() {
+ optfeature_header "Optional outuput support:"
optfeature "png output support" dev-perl/GD[png]
+ optfeature "spreadsheet output support" dev-python/xlsxwriter
+ optfeature_header "Optional language support:"
+ optfeature "Python code coverage support" dev-python/coverage
+ optfeature "Perl code coverage support" dev-perl/Devel-Cover
}