summaryrefslogtreecommitdiff
path: root/dev-util/librnp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
commitd2e43b44e8855b7ee7b79782358dee45099efccc (patch)
treeb6dd4c6cf2a46f31df970692a4aed40056dff35e /dev-util/librnp
parent1a256280f70812d1ae23f0ce2a2569291b6609da (diff)
gentoo auto-resync : 25:09:2022 - 11:33:33
Diffstat (limited to 'dev-util/librnp')
-rw-r--r--dev-util/librnp/Manifest2
-rw-r--r--dev-util/librnp/librnp-0.16.1.ebuild76
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-util/librnp/Manifest b/dev-util/librnp/Manifest
index fa754a4ff2e7..4aa213b410de 100644
--- a/dev-util/librnp/Manifest
+++ b/dev-util/librnp/Manifest
@@ -1,5 +1,3 @@
-DIST librnp-0.16.1.tar.gz 2897069 BLAKE2B 0ce261a5f1229ab1567d4726b8d75eaf3fa72774ef66280bd587f28282371cde9691de24de329f8209f99c76dc6cf01e7c711e1bd3fd47b8b145762936a1b655 SHA512 948d8c1342c34ec850605b79b490d6da3094b4fb1f8435f4c928473c15a0df364f2ad56091f4b746afc98119d85137cf7b341c72054ccac79ab236f13cca48f4
DIST librnp-0.16.2.tar.gz 2897137 BLAKE2B 5f756047506531e0ed3d431cebd3977f3492b464445f6dc54850badc795478f5d04ff036147e8212b4a3e2d4fd939f4bcf668e9a260c2e7fc616ef51dea02117 SHA512 5fd5fceb39429e130adafd4869d9a01149d9c08271770da4eedbe75910788f8256c8bf19e6bb0886a902b22dd5564eb93baddaf84689cbf5e6617674f4f0efac
-EBUILD librnp-0.16.1.ebuild 1747 BLAKE2B 09dd5d19778e51b1b66bc2ed5b6bcb2fc0a2fbac93283ea90f883cca8e5af26e138a5d4bfa8fd7421d58f9f980e53367bc6d2a7e9398fca25eeb6c37902d2790 SHA512 79f346bc6a991503d0791e12fce50f8e98ea604e14e9e5df3edb7b0317429cdb575c5bdd1328bcf7c9c356b18d032842704de848682d738d476e18cc1a74c43b
EBUILD librnp-0.16.2.ebuild 1621 BLAKE2B 36d97936371e4c8c4f4c6abf21c2f34eb39b113731a89a4d595a191eaaa745940c05818eef87cfd653615b17b3fdba776c7c61d658c07cf2a26cf5efb299304b SHA512 802d1f54b978f8940abc18fb09af1964288aaef944c5b6f09c506e071cea19bf68a9669df894f0427430a354057e1457e56642abe38a1d70ecaed86cd22805a7
MISC metadata.xml 430 BLAKE2B 739d6cddc56f385ad2b1679f6b3d9ba567ce77ec536894ca3861ad7ad127fd60c395db49b31d89963df12c03d8cf69fc6f083f5d3361b790079952c1e76ccf03 SHA512 ad7b3e6332741e1f2eae9e158d5ca767f5985a8f5c86eb5f21b7ee0214b9c7fdd2e90beddf1a9287218edf35aff39bd7ff1a4f1d15eb10552ab664738f8d1959
diff --git a/dev-util/librnp/librnp-0.16.1.ebuild b/dev-util/librnp/librnp-0.16.1.ebuild
deleted file mode 100644
index b6ba813ff651..000000000000
--- a/dev-util/librnp/librnp-0.16.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="High performance C++ OpenPGP library"
-HOMEPAGE="https://www.rnpgp.org/ https://github.com/rnpgp/rnp"
-SRC_URI="https://github.com/rnpgp/rnp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2"
-SLOT="0/0.16.1"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="+botan man test"
-
-RDEPEND="app-arch/bzip2
- dev-libs/json-c:=
- sys-libs/zlib
- botan? ( dev-libs/botan:2= )
- !botan? ( >=dev-libs/openssl-1.1.1:= )"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-BDEPEND="man? ( dev-ruby/asciidoctor )"
-
-RESTRICT="!test? ( test )"
-S="${WORKDIR}/${P/*lib/}"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test on off)
-
- -DCRYPTO_BACKEND=$(usex botan botan openssl)
-
- -DDOWNLOAD_GTEST=off
- -DDOWNLOAD_RUBYRNP=off
-
- -DENABLE_COVERAGE=off
- -DENABLE_DOC=$(usex man on off)
- -DENABLE_FUZZERS=off
- -DENABLE_SANITIZERS=off
- )
-
- if use botan; then
- local mycmakeargs+=(
- -DENABLE_AEAD=on
- -DENABLE_BRAINPOOL=on
- -DENABLE_SM2=on
- -DENABLE_TWOFISH=on
- )
-
- # OpenSSL support is still not as complete as botan.
- # https://github.com/rnpgp/rnp/issues/1642 AEAD,
- # https://github.com/rnpgp/rnp/issues/1902 BRAINPOOL,
- # https://github.com/rnpgp/rnp/issues/1877 SM2,
- # https://github.com/openssl/openssl/issues/2046 TWOFISH.
- else
- local mycmakeargs+=(
- -DENABLE_AEAD=off
- -DENABLE_BRAINPOOL=off
- -DENABLE_SM2=off
- -DENABLE_TWOFISH=off
- )
- fi
-
- # Broken in 0.16.1.
- # https://github.com/rnpgp/rnp/issues/1901
- local mycmakeargs+=( -DENABLE_IDEA=off )
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- ctest -j"${MAKEOPTS}" -R .* --output-on-failure || die
-}