summaryrefslogtreecommitdiff
path: root/dev-util/ltrace/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
commit2b2f431a0021b4787ca3c028cefb30ad81347778 (patch)
tree951e0155f53027c8fd29eaba26df4f08292668d5 /dev-util/ltrace/files
parentd725480af7cbc67d784e5d96f973fa41e9030123 (diff)
gentoo auto-resync : 19:01:2024 - 20:08:27
Diffstat (limited to 'dev-util/ltrace/files')
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-CXX-for-tests.patch11
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch12
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-ia64-pid_t.patch6
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-ia64.patch39
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-musl-host.patch11
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.3-print-test-pie.patch15
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.91-debian-patchset-6.4.patch77
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.91-pid_t.patch10
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.91-test-glibc-2.33.patch11
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.91-tuple-tests.patch11
10 files changed, 0 insertions, 203 deletions
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-CXX-for-tests.patch b/dev-util/ltrace/files/ltrace-0.7.3-CXX-for-tests.patch
deleted file mode 100644
index 06db36c46818..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-CXX-for-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Testsuite uses CXX to trace mangled symbols.
---- a/configure.ac
-+++ b/configure.ac
-@@ -53,6 +53,7 @@ AC_SUBST(HOST_CPU)
-
- # Checks for programs.
- AC_PROG_CC
-+AC_PROG_CXX
- LT_INIT
- # libtool-2: LT_INIT()
- AM_INIT_AUTOMAKE([foreign no-exeext dist-bzip2])
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch b/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
deleted file mode 100644
index 7ff573272963..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-alpha-protos.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix build failure on alpha:
- plt.c:32:12: error: dereferencing pointer to incomplete type ‘struct library_symbol’
- return sym->enter_addr;
- ^
---- a/sysdeps/linux-gnu/alpha/plt.c 2012-11-10 13:43:55.000000000 +0100
-+++ b/sysdeps/linux-gnu/alpha/plt.c 2016-06-27 23:21:28.000000000 +0200
-@@ -23,0 +24 @@
-+#include "library.h"
---- a/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:30:08.000000000 +0200
-+++ b/sysdeps/linux-gnu/alpha/trace.c 2016-06-27 23:25:20.000000000 +0200
-@@ -29,0 +30 @@
-+#include "backend.h"
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-ia64-pid_t.patch b/dev-util/ltrace/files/ltrace-0.7.3-ia64-pid_t.patch
deleted file mode 100644
index c466ce17e02d..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-ia64-pid_t.patch
+++ /dev/null
@@ -1,6 +0,0 @@
---- a/sysdeps/linux-gnu/ia64/breakpoint.c
-+++ b/sysdeps/linux-gnu/ia64/breakpoint.c
-@@ -26,2 +26,3 @@
- #include <sys/ptrace.h>
-+#include <sys/types.h> /* pid_t */
- #include <string.h>
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-ia64.patch b/dev-util/ltrace/files/ltrace-0.7.3-ia64.patch
deleted file mode 100644
index 4fb1c4eba734..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-ia64.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Fix build fauilure on ia64.
-
-Build fails due to bitrot: some definitions
-moved off from <sys/pthrace.h> to <asm/ptrace.h>
-(similar to other arches).
-
-fetch.c:39:26: error: field 'regs' has incomplete type
- struct pt_all_user_regs regs;
- ^~~~
-fetch.c:209:25: warning: 'struct ia64_fpreg' declared inside parameter list will not be visible outside of this definition or declaration
- fpreg_to_double (struct ia64_fpreg *fp) {
- ^~~~~~~~~~
-fetch.c: In function 'fpreg_to_double':
-fetch.c:211:45: error: dereferencing pointer to incomplete type 'struct ia64_fpreg'
- asm ("ldf.fill %0=%1" : "=f"(result) : "m"(*fp));
- ^~~
-
-diff --git a/sysdeps/linux-gnu/ia64/fetch.c b/sysdeps/linux-gnu/ia64/fetch.c
-index 54dc5b8..b3b9a9a 100644
---- a/sysdeps/linux-gnu/ia64/fetch.c
-+++ b/sysdeps/linux-gnu/ia64/fetch.c
-@@ -134,9 +134,4 @@ allocate_reg(struct fetch_context *ctx, struct Process *proc,
- return 0;
-
-- /* This would normally be brought over from asm/ptrace.h, but
-- * when we do, we get namespace conflicts between asm/fpu.h
-- * and libunwind. */
-- enum { PT_AUR_BSP = 17 };
--
- union cfm_t cfm = { .value = ctx->regs.cfm };
- unsigned long *bsp = (unsigned long *)ctx->regs.ar[PT_AUR_BSP];
-diff --git a/sysdeps/linux-gnu/ia64/ptrace.h b/sysdeps/linux-gnu/ia64/ptrace.h
-index ef63b4f..8b131f1 100644
---- a/sysdeps/linux-gnu/ia64/ptrace.h
-+++ b/sysdeps/linux-gnu/ia64/ptrace.h
-@@ -20,2 +20,3 @@
-
- #include <sys/ptrace.h>
-+#include <asm/ptrace.h>
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-musl-host.patch b/dev-util/ltrace/files/ltrace-0.7.3-musl-host.patch
deleted file mode 100644
index 7729449d0604..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-musl-host.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-https://bugs.gentoo.org/713428
---- a/configure.ac
-+++ b/configure.ac
-@@ -33,6 +33,7 @@ AC_CANONICAL_HOST
-
- case "${host_os}" in
- linux-gnu*) HOST_OS="linux-gnu" ;;
-+ linux-musl*) HOST_OS="linux-gnu" ;;
- linux-uclibc*) HOST_OS="linux-gnu" ;;
- *) AC_MSG_ERROR([unkown host-os ${host_os}]) ;;
- esac
diff --git a/dev-util/ltrace/files/ltrace-0.7.3-print-test-pie.patch b/dev-util/ltrace/files/ltrace-0.7.3-print-test-pie.patch
deleted file mode 100644
index 5e46135add3e..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.3-print-test-pie.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/testsuite/ltrace.minor/print-instruction-pointer.exp
-+++ b/testsuite/ltrace.minor/print-instruction-pointer.exp
-@@ -32,6 +32,12 @@ catch "exec sh -c {objdump -d $objdir/$subdir/$binfile | sed -n '/^\[0-9a-fA-F\]
- catch "exec sh -c {echo \"$output\" | sed -n '2p'| awk -F' ' '{print \$1}'|awk -F: '{print \$1}'}" addr1
- catch "exec sh -c {echo \"$output\" | sed -n '5p'| awk -F' ' '{print \$1}'|awk -F: '{print \$1}'}" addr2
-
-+# Pick at most last 3 digits:
-+# PIE binaries randomize address on page level.
-+# Let's assume page size is no bigger than 4096 (3 hex digits)
-+set addr1 [string range $addr1 3 end]
-+set addr2 [string range $addr2 3 end]
-+
- verbose "addr1 = $addr1"
- verbose "addr2 = $addr2"
- # Verify the output by checking numbers of print in main.ltrace.
diff --git a/dev-util/ltrace/files/ltrace-0.7.91-debian-patchset-6.4.patch b/dev-util/ltrace/files/ltrace-0.7.91-debian-patchset-6.4.patch
deleted file mode 100644
index 1f3bb5ec6a21..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.91-debian-patchset-6.4.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-Patches imported from the Debian patch set 6.4 for ltrace-0.7.3:
- - 01-avoid-libstdc++ (adapted to account for the absence of configure),
- - 03-alpha-debug.h
- - 05-sparc-ftbfs
- - 06-unexpected-breakpoint
-The other two have since been merged upstream.
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -126,6 +126,15 @@
- libstdcxx_LIBS=""])
- AC_SUBST(libstdcxx_LIBS)
-
-+if test "x$liberty_LIBS" != "x"
-+then
-+ libsupcxx_LIBS=""
-+ libstdcxx_LIBS=""
-+elif test "x$libsupcxx_LIBS" != "x"
-+then
-+ libstdcxx_LIBS=""
-+fi
-+
-
- dnl Check security_get_boolean_active availability.
- AC_CHECK_HEADERS(selinux/selinux.h)
---- a/handle_event.c
-+++ b/handle_event.c
-@@ -740,9 +740,12 @@
-
- if ((sbp = address2bpstruct(leader, brk_addr)) != NULL)
- breakpoint_on_hit(sbp, event->proc);
-- else if (event->proc->state != STATE_IGNORED)
-+ else if (event->proc->state != STATE_IGNORED) {
- output_line(event->proc,
- "unexpected breakpoint at %p", brk_addr);
-+ continue_process(event->proc->pid);
-+ return;
-+ }
-
- /* breakpoint_on_hit may delete its own breakpoint, so we have
- * to look it up again. */
---- a/sysdeps/linux-gnu/alpha/trace.c
-+++ b/sysdeps/linux-gnu/alpha/trace.c
-@@ -29,7 +29,6 @@
-
- #include "proc.h"
- #include "common.h"
--#include "debug.h"
-
- #if (!defined(PTRACE_PEEKUSER) && defined(PTRACE_PEEKUSR))
- # define PTRACE_PEEKUSER PTRACE_PEEKUSR
---- a/sysdeps/linux-gnu/sparc/plt.c
-+++ b/sysdeps/linux-gnu/sparc/plt.c
-@@ -19,8 +19,9 @@
- */
-
- #include <gelf.h>
-+
- #include "proc.h"
--#include "common.h"
-+#include "library.h"
-
- GElf_Addr
- arch_plt_sym_val(struct ltelf *lte, size_t ndx, GElf_Rela * rela) {
---- a/sysdeps/linux-gnu/sparc/trace.c
-+++ b/sysdeps/linux-gnu/sparc/trace.c
-@@ -26,8 +26,10 @@
- #include <sys/wait.h>
- #include <signal.h>
- #include <string.h>
-+
- #include "ptrace.h"
- #include "proc.h"
-+#include "backend.h"
- #include "common.h"
-
- void
diff --git a/dev-util/ltrace/files/ltrace-0.7.91-pid_t.patch b/dev-util/ltrace/files/ltrace-0.7.91-pid_t.patch
deleted file mode 100644
index 06075006b2e1..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.91-pid_t.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/proc.h
-+++ b/proc.h
-@@ -27,6 +27,7 @@
-
- #include <sys/time.h>
- #include <stdint.h>
-+#include <unistd.h> /* pid_t */
-
- #if defined(HAVE_LIBDW)
- # include <elfutils/libdwfl.h>
diff --git a/dev-util/ltrace/files/ltrace-0.7.91-test-glibc-2.33.patch b/dev-util/ltrace/files/ltrace-0.7.91-test-glibc-2.33.patch
deleted file mode 100644
index b78d4580b050..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.91-test-glibc-2.33.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/testsuite/ltrace.main/system_calls.exp
-+++ b/testsuite/ltrace.main/system_calls.exp
-@@ -133,7 +133,7 @@
- { {^write$} == 1 }
- { {^unlink(at)?$} >= 2 }
- { {^open(at)?$} == 1 }
-- { {^(new|f)?stat(64)?$} >= 1 }
-+ { {^(new)?stat|fstatat64|newfstatat$} >= 1 }
- { {^close$} == 1 }
- { {^getcwd$} == 1 }
- { {^chdir$} == 1 }
diff --git a/dev-util/ltrace/files/ltrace-0.7.91-tuple-tests.patch b/dev-util/ltrace/files/ltrace-0.7.91-tuple-tests.patch
deleted file mode 100644
index c7c997d5545e..000000000000
--- a/dev-util/ltrace/files/ltrace-0.7.91-tuple-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/testsuite/Makefile.am
-+++ b/testsuite/Makefile.am
-@@ -42,6 +42,8 @@
- echo set elfutils_LD_LIBRARY_PATH '"$(elfutils_LD_LIBRARY_PATH)"' >> $@
- echo set libunwind_LD_LIBRARY_PATH '"$(libunwind_LD_LIBRARY_PATH)"' >> $@
- echo set PREFIX '"$(prefix)"' >> $@
-+ echo set CC_FOR_TARGET '"$(CC)"' >> $@
-+ echo set CXX_FOR_TARGET '"$(CXX)"' >> $@
-
- CLEANFILES = *.o *.so *.log *.sum *.ltrace site.bak setval.tmp site.exp env.exp
-