summaryrefslogtreecommitdiff
path: root/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/lttng-ust/lttng-ust-2.8.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.8.1.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.8.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild b/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild
new file mode 100644
index 000000000000..98b7ef0251ea
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools versionator
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}