summaryrefslogtreecommitdiff
path: root/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild')
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild
new file mode 100644
index 000000000000..60e7f2c36aad
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtcore-5.15:5
+"
+RDEPEND="${DEPEND}"