summaryrefslogtreecommitdiff
path: root/dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 07:29:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 07:29:33 +0100
commit4cc852b4016d8aa1fa4d7a8b3911bebe1ed1da50 (patch)
tree63c3a168bb59a510954fae0dc96a9f4658d22b31 /dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild
parentad75ca50360f9590325f0f709c091832b70eab1d (diff)
gentoo auto-resync : 08:10:2022 - 07:29:32
Diffstat (limited to 'dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild')
-rw-r--r--dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild b/dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild
new file mode 100644
index 000000000000..1dd28afb54b3
--- /dev/null
+++ b/dev-util/min-cscope/min-cscope-16.1.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="https://sourceforge.net/projects/kscope/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README{,.cscope} TODO )
+
+PATCHES=(
+ "${FILESDIR}/${P}-tinfo.patch" # bug #678886
+ "${FILESDIR}/${P}-pointer-type.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ echo 'INSTALL(TARGETS min-cscope RUNTIME DESTINATION bin)' \
+ >> src/CMakeLists.txt || die
+}
+
+src_configure() {
+ # -D_GNU_SOURCE for qsort_r, bug #871162
+ append-cppflags -I"${S}"/sort -D_GNU_SOURCE
+
+ cmake_src_configure
+}