summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-toolchain
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-16 20:05:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-16 20:05:31 +0000
commit03aa42efc090f9ed79ad5d8cbb54789052863450 (patch)
treec0ea2c0dffc2e24efd3ca7480551cbdc5efca4cf /dev-util/mingw64-toolchain
parentc1fba876b88db3fefeead96efa966559036e656b (diff)
gentoo auto-resync : 16:01:2024 - 20:05:31
Diffstat (limited to 'dev-util/mingw64-toolchain')
-rw-r--r--dev-util/mingw64-toolchain/Manifest2
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild9
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-util/mingw64-toolchain/Manifest b/dev-util/mingw64-toolchain/Manifest
index 97428ccd828d..4254dacc8760 100644
--- a/dev-util/mingw64-toolchain/Manifest
+++ b/dev-util/mingw64-toolchain/Manifest
@@ -3,5 +3,5 @@ AUX gcc-13.2.0-libcxx-17.patch 1158 BLAKE2B c6ea274e12b06ee9c806b6790cdaffc3bafe
DIST binutils-2.41.tar.xz 26765692 BLAKE2B 3bccec2b52f7e82a727121bf2a2e51a6249ba63dcd74c665fd834e858645c912ffd8245d848435288b938852830b482905606f55c40df4061215fd75c52ffc75 SHA512 5df45d0bd6ddabdce4f35878c041e46a92deef01e7dea5facc97fd65cc06b59abc6fba0eb454b68e571c7e14038dc823fe7f2263843e6e627b7444eaf0fe9374
DIST gcc-13.2.0.tar.xz 87858592 BLAKE2B 0034b29d3d6cc05821f0c4253ce077805943aff7b370729dd203bda57d89c107edd657eeddc2fb1e69ea15c7b0323b961f46516c7f4af89a3ccf7fea84701be2 SHA512 d99e4826a70db04504467e349e9fbaedaa5870766cda7c5cab50cdebedc4be755ebca5b789e1232a34a20be1a0b60097de9280efe47bdb71c73251e30b0862a2
DIST mingw-w64-v11.0.0.tar.bz2 10058657 BLAKE2B 3f7637bcc7c3f25b2141d35105ea086eab74e228d7275725ffb4f07e283fd75169dbe0900a9c29494fba9ddb2ea03bdd6ae26f06048311e9c93ae3e317c4c060 SHA512 bc1c9fd9d8593ead9375fcbe40950f06cf7616b94dc676db2793ac9b496fe3a6cc94b5793effda3b752942be0d7d01a1c37a8f221aaf178df0d4eeb0aa6d1f8d
-EBUILD mingw64-toolchain-11.0.0_p2.ebuild 10089 BLAKE2B 98ef10005308ed03be942ceb5d2cbfa9b86ffafef8427586a7b9d7eb75af272098a2393026a7c238aa67432fbafb6dca9cbcfea1beee3c1a4fe35d922db9c6b9 SHA512 a43b0d0990a5679ee66123ca3b1a22d35b5e8aa9cd112b16cc9e0fd2ecc82c6b749fe85a6c72c7de37ce0a04b0a6ecc5a045bc4826027f7c95380e6429890c12
+EBUILD mingw64-toolchain-11.0.0_p2.ebuild 10134 BLAKE2B 68cccef7623dea8bb4bcd66fdb652a886730b4d722223a89d26d655ee447d6628b4a8a152f13f4ec7c644fd1fe0cb1e6430155d250f9af730731e7d32deba9de SHA512 b5e9e9fb73357122926d9ec43cf28415b801c6d33826e3cb81e0b7e5295795887c6fe3509519481da47d7d8755d2bd92fa5d78ddf17e0904dfa9d5f5c3c2fc09
MISC metadata.xml 432 BLAKE2B 273e7dd75d25bd1857a83a8fbad8705413e2780589beca8e9841fabd266f1e94d6f85875901829cbdd5bfd979d23c1ebacb3b07a04cb48388e0a10656ade6cca SHA512 71bf6b85f6b8b8640167a464296199f8d91d36ef048a21a1bd55383dc5ee6ccace50b153e6945163d197f8227f05c2f339899e5b3c5c67e01896241326b2f313
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
index 7196f0b85f19..808cdc0731ae 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -100,7 +100,8 @@ src_compile() {
local conf=(
--build=${CBUILD:-${CHOST}}
--target=${CTARGET}
- --{doc,info,man}dir=/.skip # let individual packages handle docs
+ --{doc,info,man}dir=/.skip # let the real binutils+gcc handle docs
+ MAKEINFO=: #922230
)
# binutils
@@ -239,9 +240,9 @@ src_compile() {
pushd "${build_dir}" >/dev/null || die
edo "${conf[@]}"
- emake V=1
+ emake MAKEINFO=: V=1
# -j1 to match bug #906155, other packages may be fragile too
- emake -j1 V=1 DESTDIR="${MWT_D}" install
+ emake -j1 MAKEINFO=: V=1 DESTDIR="${MWT_D}" install
declare -f mwt-${id} >/dev/null && edo mwt-${id}
declare -f mwt-${id}_${2} >/dev/null && edo mwt-${id}_${2}