summaryrefslogtreecommitdiff
path: root/dev-util/ninja/ninja-1.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-util/ninja/ninja-1.8.2-r1.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-util/ninja/ninja-1.8.2-r1.ebuild')
-rw-r--r--dev-util/ninja/ninja-1.8.2-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-util/ninja/ninja-1.8.2-r1.ebuild b/dev-util/ninja/ninja-1.8.2-r1.ebuild
index caa2bb8e6460..84c7f67ce665 100644
--- a/dev-util/ninja/ninja-1.8.2-r1.ebuild
+++ b/dev-util/ninja/ninja-1.8.2-r1.ebuild
@@ -1,17 +1,20 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs vcs-snapshot
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ninja-build/ninja.git"
else
- SRC_URI="https://github.com/Kitware/${PN}/archive/v${PV}.g3bbbe.kitware.dyndep-1.jobserver-1.tar.gz -> ${P}-fortran.tar.gz"
+ KITWARE_VERSION="1.8.2.g3bbbe.kitware.dyndep-1.jobserver-1"
+ MY_P="ninja-${KITWARE_VERSION}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/Kitware/ninja/archive/v${KITWARE_VERSION}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
fi
@@ -44,8 +47,6 @@ RDEPEND="
zsh-completion? ( app-shells/zsh )
!<net-irc/ninja-1.5.9_pre14-r1" #436804
-S="${WORKDIR}/${P}-fortran"
-
run_for_build() {
if tc-is-cross-compiler; then
local -x AR=$(tc-getBUILD_AR)