summaryrefslogtreecommitdiff
path: root/dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild')
-rw-r--r--dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild b/dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild
new file mode 100644
index 000000000000..c2f92aa1c358
--- /dev/null
+++ b/dev-util/opencl-headers/opencl-headers-2022.01.04.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="OpenCL-Headers"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Unified C language headers for the OpenCL API"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-Headers"
+SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"/${MY_P}
+
+src_install() {
+ insinto /usr/include
+ doins -r "${S}"/CL
+
+ einstalldocs
+}