summaryrefslogtreecommitdiff
path: root/dev-util/ostree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-util/ostree
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-util/ostree')
-rw-r--r--dev-util/ostree/Manifest4
-rw-r--r--dev-util/ostree/metadata.xml2
-rw-r--r--dev-util/ostree/ostree-2018.9.ebuild107
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index 05157ac3dbe9..17ec74303364 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -1,3 +1,5 @@
DIST ostree-2018.5.tar.xz 1937184 BLAKE2B ff126d2963296eb9ac270816efed7d2fbfdbcc7b0dba69007ae83e4499a46ef21a5b4e5d387de9bd387af0fe8d4086427d1aa9043c246a49676d116e919a93e6 SHA512 03854c662cddc1e0c7150bb62bbdd2990cf091ef126ddc5bb94494fee2ffb0383afb067b89d63c3e4f39849e2c8b7cabfd887d0d6fc1e7a43fda4fe7da1dc2e8
+DIST ostree-2018.9.tar.xz 1951732 BLAKE2B c6fba1321fe21bff569fe1dadd1aa649f23059a35dc906c3a0b7dcca29f7acbe8338e19541d8f7d854452bf6a6b1ac293d4350c7056a9b13b9ed1eacf358d4b3 SHA512 407b6b67add54e80a55fc35f08bde56561009db93ec202a10dd1ec1e66bd32b439c1d66c759e4e173e44fce6fbc2c162cae928a477c9d7abafbf007ed8f7bfb5
EBUILD ostree-2018.5.ebuild 1183 BLAKE2B 749134dbf4e826fd6535cdd94ff66704d136404a1864d8dbbb7bf075cc42d89bd7091100d31fdc0a81b13aa452075c3ae3f4c6fe9d4931ada5e20a6a9d6cc65b SHA512 f1bb169d68fc6658b986b6d443537e6e1a7a05386588a966de08ef9c6da370524abb11ce6b8b95e94a7eeec7cefa4ced461526ffd8abbb1ee123457cc5de02f6
-MISC metadata.xml 1644 BLAKE2B 3085135779d4dbefb278b1b7ca4e80e4b892f38585aea5a71fde726d55b9975c0c097917940045a0770a5d8bc2c3732a371773a8cb6750dd272ca0b4a9488182 SHA512 5fb6f77a5068d1ff4aab1635ba41ed895f6b31cce39b571b4f3487c68242bb5634e7454bce318d0c585cb581533d1fe239344a9eb7f1485c4b75a5a24d78f5ad
+EBUILD ostree-2018.9.ebuild 3219 BLAKE2B cfb584f4e3e8e38eb9df1016aaf7778eade21b6570d39c399c22facfd5dbce1c9d7e5e0db920820c645e0d9c2c04ca4b9c22668fa39bb0e499ad1e176592903d SHA512 8f32a3f915b1222850b3c1cbe75af5dff6013a38b6c8c3510aa4e5b27f8553fc9122c7df164bd30c96be832c00c695ab5dc7d8a0c881c96fbba077efc693257b
+MISC metadata.xml 1733 BLAKE2B 81ec9a732f50e49d589e385e6f88a99a629098d2f172aa398ac819fb4e343d2c172c86f92c778d402623f8b7b1143ca8f19f3f3c9ff30fab7fe89dd20ce1428f SHA512 56f083cd71d111275d59dc2759da9ec7685deb01890476da499b56ed82d873bdbe0a0e76f5c07a8c9f2efc3219c34884df2fe4c6b7407363abcc2b6ce066ddbd
diff --git a/dev-util/ostree/metadata.xml b/dev-util/ostree/metadata.xml
index d31a82267686..4fb7a62d6f22 100644
--- a/dev-util/ostree/metadata.xml
+++ b/dev-util/ostree/metadata.xml
@@ -30,7 +30,9 @@
it's just a more polished version of Linux VServer hardlinks.
</longdescription>
<use>
+ <flag name="archive">Use libarchive</flag>
<flag name="grub">Enable grub configuration generator</flag>
+ <flag name="libmount">Use libmount</flag>
<flag name="soup">Use libsoup for networking</flag>
</use>
<upstream>
diff --git a/dev-util/ostree/ostree-2018.9.ebuild b/dev-util/ostree/ostree-2018.9.ebuild
new file mode 100644
index 000000000000..495e21ac476f
--- /dev/null
+++ b/dev-util/ostree/ostree-2018.9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostree.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/ostreedev/${PN}/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="archive curl doc gnutls grub introspection libmount selinux ssl soup systemd zeroconf"
+RESTRICT="test"
+
+S="${WORKDIR}/lib${P}"
+COMMON_DEPEND="
+ app-arch/xz-utils:=
+ app-crypt/gpgme:=
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ dev-libs/openssl:=
+ sys-apps/util-linux:=
+ sys-fs/fuse:=
+ sys-libs/zlib:=
+
+ archive? ( app-arch/libarchive:= )
+ grub? ( sys-boot/grub:* )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+ libmount? ( sys-apps/util-linux:= )
+ selinux? ( sys-libs/libselinux:= )
+ soup? ( net-libs/libsoup:= )
+ systemd? ( sys-apps/systemd:= )
+ zeroconf? ( net-dns/avahi:* )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ sys-devel/bison
+ dev-libs/libxslt
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ curl? ( net-misc/curl:= )
+ introspection? ( dev-libs/gobject-introspection )
+ doc? ( dev-util/gtk-doc )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ default
+ sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
+ -i Makefile.in Makefile-man.am || die
+
+ # The ostree-finalize-staged.path file is missing in ostree-2018.9.tar.xz.
+ [[ -e src/boot/ostree-finalize-staged.path ]] && die
+ cat > src/boot/ostree-finalize-staged.path <<-EOF
+ # Copyright (C) 2018 Red Hat, Inc.
+ #
+ # This library is free software; you can redistribute it and/or
+ # modify it under the terms of the GNU Lesser General Public
+ # License as published by the Free Software Foundation; either
+ # version 2 of the License, or (at your option) any later version.
+ #
+ # This library is distributed in the hope that it will be useful,
+ # but WITHOUT ANY WARRANTY; without even the implied warranty of
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ # Lesser General Public License for more details.
+ #
+ # You should have received a copy of the GNU Lesser General Public
+ # License along with this library; if not, write to the
+ # Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ # Boston, MA 02111-1307, USA.
+
+ # For some implementation discussion, see:
+ # https://lists.freedesktop.org/archives/systemd-devel/2018-March/040557.html
+ [Unit]
+ Description=OSTree Monitor Staged Deployment
+ Documentation=man:ostree(1)
+
+ [Path]
+ PathExists=/run/ostree/staged-deployment
+
+ [Install]
+ WantedBy=multi-user.target
+ EOF
+}
+
+src_configure() {
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf \
+ --enable-man \
+ $(use_with archive libarchive) \
+ $(use_with curl) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_with selinux ) \
+ $(use_with soup) \
+ $(use_with libmount) \
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; }) \
+ $(use_with systemd libsystemd) \
+ $(use_with zeroconf avahi)
+}