summaryrefslogtreecommitdiff
path: root/dev-util/packer/packer-1.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-util/packer/packer-1.7.2.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-util/packer/packer-1.7.2.ebuild')
-rw-r--r--dev-util/packer/packer-1.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.7.2.ebuild b/dev-util/packer/packer-1.7.2.ebuild
new file mode 100644
index 000000000000..302cc7c43eea
--- /dev/null
+++ b/dev-util/packer/packer-1.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ go build \
+ -ldflags "${go_ldflags}" \
+ -mod=vendor \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}