summaryrefslogtreecommitdiff
path: root/dev-util/packer/packer-1.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 16:03:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 16:03:04 +0100
commit29ef84a753ab20dbbb228238713a3c7443c6520e (patch)
treeebe889f9f8817c5c6601a6dbfd0b12d537b4e91d /dev-util/packer/packer-1.9.4.ebuild
parentcf89ca044e37f79e2329552cda857215f9824e11 (diff)
gentoo auto-resync : 17:10:2023 - 16:03:04
Diffstat (limited to 'dev-util/packer/packer-1.9.4.ebuild')
-rw-r--r--dev-util/packer/packer-1.9.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.9.4.ebuild b/dev-util/packer/packer-1.9.4.ebuild
new file mode 100644
index 000000000000..20a7d1166c80
--- /dev/null
+++ b/dev-util/packer/packer-1.9.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gentoo.neutroniak.com/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ ego build \
+ -mod=readonly \
+ -ldflags "${go_ldflags}" \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}