summaryrefslogtreecommitdiff
path: root/dev-util/patchelf/patchelf-0.17.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-25 03:53:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-25 03:53:16 +0100
commitfad7c346bcf147b6a580ccc1d0a9b35dbe194ecc (patch)
treead2e2924d725873f214407741185a257944d8ed9 /dev-util/patchelf/patchelf-0.17.2.ebuild
parent27ddeb821d437a2d848d9fa85a30f88f48fb52a6 (diff)
gentoo auto-resync : 25:08:2023 - 03:53:16
Diffstat (limited to 'dev-util/patchelf/patchelf-0.17.2.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.17.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.17.2.ebuild b/dev-util/patchelf/patchelf-0.17.2.ebuild
new file mode 100644
index 000000000000..968fd2dbe7bd
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.17.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}