summaryrefslogtreecommitdiff
path: root/dev-util/plan9port
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
commit996d1cba721b044876526a7f3c1d2ef1fcc90bb4 (patch)
tree16fac72b3f131ad5671db34f88cd6426ff602706 /dev-util/plan9port
parent0cfdfb9b75c154c98f3963d4a002425218e29efc (diff)
gentoo auto-resync : 06:06:2023 - 09:39:05
Diffstat (limited to 'dev-util/plan9port')
-rw-r--r--dev-util/plan9port/Manifest2
-rw-r--r--dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild141
2 files changed, 143 insertions, 0 deletions
diff --git a/dev-util/plan9port/Manifest b/dev-util/plan9port/Manifest
index 7514f3759a9e..a355ae0254df 100644
--- a/dev-util/plan9port/Manifest
+++ b/dev-util/plan9port/Manifest
@@ -2,5 +2,7 @@ AUX plan9port-builderr.patch 882 BLAKE2B 1526bad2833a416cfb214f047f2f14bda89ca82
AUX plan9port-cflags.patch 312 BLAKE2B d09a4bb70451beb0cb6de05be37c6d68334d51f4db882debde4e3f3accf3aec25054ad5411a3c7289df6b556f59c1a729005f1c21247545158879c429462843d SHA512 29c4419bbc36330b322541b625bbe9131ed14d01008ba2ab2865a175918506de1e96a2b078246d1d6b6bc48537f90f74b1a72b223d74dc73d13cb7cf63d33c58
AUX plan9port-noexecstack.patch 384 BLAKE2B 7f887894113677df743f64d7b1015aa65837818aff3c8d93bb553177da377a5975e7f8841addfff6b533771085490d306124adaf62a834615f0f5ca46f455bf4 SHA512 833a331d963e1f02ce497ffb293750cd6c535b6b2d6d26a2218264d3a7aa098b30f95cb3968fbaa3a734505286ff560e65f0390154af6a324078e3d7f80385be
DIST plan9port-88a87fadae6629932d9c160f53ad5d79775f8f94.tar.gz 23413373 BLAKE2B 6145dd77c9e4b33ebc6d68f42ed69e320e8bfcaae474a16afb3a62e30c13a39117d7013f3cc075eb48c95a5600c4fdb457e45f65f7b25ad2acc7b19dc9cf8e64 SHA512 f008969274e790238b58ebd0d0dcfaa730557daf974797f8c4014c36ac39995b330db9c6d658655358fdb2be64905b83c35e2287b7cd66b2d3249e1da1a3e119
+DIST plan9port-cc4571fec67407652b03d6603ada6580de2194dc.tar.gz 23411459 BLAKE2B 439ea7dcddfc466a7fe8bea8b75a7e73558e5cdbd7f0adf9b3367d6eab9eaab8afa8e9fb60bcf83a4a614abbd52a85ddfa65b5dd757fdd2b725f554bf66f3c90 SHA512 e347ffd04c92508b3bc324d93837c831af40b5eb11583f6c61e15c0e861067c76945a1a65929c1e725f18760035a1a14a6cd16a7b8b6a14fd2422750cef1e4d4
EBUILD plan9port-0_pre20210321.ebuild 3770 BLAKE2B 1301ab238c1bfdee211cba8a8affa038a4a80b1620ec694a0ae3091464f01c6045b4eeb97aecb2d5ea08d434e702bba9b3f48482118cac48965342044fb6afaa SHA512 9841e41f44145ecf36fd06b4004d7911576963d8ca05d8d352b46228eed4c99f419f05acc4aebbfb4a374750a50bc818e90eb8d707c6eda93a14af18309a2f97
+EBUILD plan9port-0_pre20230331-r1.ebuild 3685 BLAKE2B 336a49954d2bc5dcf835e95226771239760945062b6da1dc956d052cd27bda5726aef8e4f7e642cf1a59cdd046db8bdf7bc8bdd8566c4d509249a869ec459b57 SHA512 7060b572a4649bd968ae640fc5c6fda263ba9331775e39d458e4c2228f2d170217ef1779cd7a6c91e06616fee716fa245e6887bfe947d699a87f7fd0d658d4fd
MISC metadata.xml 482 BLAKE2B 70ae535a97db4267a15ddc5f50c667075b5e124dcd526931fec7ca526128e28eab60ffc586f9b72a142b1b33a5b561cf5cc9a2278ec591a4c9e94df2de50a538 SHA512 3f3d15c13435cacbc31ed57263350b58681e4c868b1724ea35668c3e5f1ae5e6d12760ef8615a128349559889477db37c1dd22b653356504b623a89f4f4935e1
diff --git a/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild b/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild
new file mode 100644
index 000000000000..4373389cdfc5
--- /dev/null
+++ b/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing toolchain-funcs readme.gentoo-r1
+
+MY_HASH="cc4571fec67407652b03d6603ada6580de2194dc"
+MY_P="${PN}-${MY_HASH}"
+
+DESCRIPTION="Port of many Plan 9 programs and libraries"
+HOMEPAGE="https://9fans.github.io/plan9port/ https://github.com/9fans/plan9port"
+SRC_URI="https://github.com/9fans/${PN}/archive/${MY_HASH}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="
+ MIT RSA Apache-2.0 public-domain BitstreamVera BZIP2
+ !freefonts? ( BigelowHolmes )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="X aqua freefonts"
+REQUIRED_USE="?? ( X aqua )"
+
+DEPEND="
+ X? (
+ media-libs/freetype
+ media-libs/fontconfig
+ x11-apps/xauth
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-noexecstack.patch"
+ "${FILESDIR}/${PN}-cflags.patch"
+ "${FILESDIR}/${PN}-builderr.patch"
+)
+
+PLAN9="/opt/plan9"
+EPLAN9="${EPREFIX}${PLAN9}"
+QA_MULTILIB_PATHS="${PLAN9}/.*/.*"
+
+DOC_CONTENTS="Plan 9 from User Space has been successfully installed into
+${PLAN9}. Your PLAN9 and PATH environment variables have
+also been appropriately set, please use env-update and
+source /etc/profile to bring that into immediate effect.
+
+Please note that ${PLAN9}/bin has been appended to the
+*end* or your PATH to prevent conflicts. To use the Plan9
+versions of common UNIX tools, use the absolute path:
+${PLAN9}/bin or the 9 command (eg: 9 troff)
+
+Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
+DISABLE_AUTOFORMATTING="yes"
+
+src_prepare() {
+ default
+
+ if use freefonts; then
+ pushd font || die
+ rm -r big5 fixed jis luc{,m,sans} misc naga10 pelm shinonome || die
+ popd || die
+ rm -r postscript/font/luxi || die
+ fi
+
+ case "${CHOST}" in
+ *apple*)
+ sed -i 's/--noexecstack/-noexecstack/' src/mkhdr ||
+ die "Failed to sed AFLAGS" ;;
+ *)
+ rm -rf mac || die
+ esac
+
+ # don't hardcode /bin and /usr/bin in PATH
+ sed -i '/PATH/s,/bin:/usr/bin:,,' INSTALL || die "sed on INSTALL failed"
+
+ # don't hardcode /usr/{,local/}include and prefix /usr/include/*
+ sed -Ei -e 's,-I/usr(|/local)/include ,,g' \
+ -e "s,-I/usr(|/local)/include,-I${EPREFIX}/usr\1/include,g" \
+ src/cmd/fontsrv/freetyperules.sh INSTALL $(find -name makefile) ||
+ die "sed failed"
+
+ # Fix paths, done in place of ./INSTALL -c
+ einfo "Fixing hard-coded /usr/local/plan9 paths"
+ sed -i "s,/usr/local/plan9,${EPLAN9},g" $(grep -lr /usr/local/plan9) ||
+ die "sed failed"
+}
+
+src_configure() {
+ local -a myconf=(
+ CC9="$(tc-getCC)"
+ CC9FLAGS="'${CFLAGS} ${LDFLAGS}'"
+ )
+
+ if use X; then
+ myconf+=(
+ WSYSTYPE=x11
+ FONTSRV=fontsrv
+ )
+ elif use aqua; then
+ local wsystype="$(awk '{if ($1 > 10.5) print "osx-cocoa"; else print "osx"}' \
+ <<< "${MACOSX_DEPLOYMENT_TARGET}")"
+ myconf+=( WSYSTYPE="${wsystype}" )
+ else
+ myconf+=( WSYSTYPE=nowsys )
+ fi
+
+ printf '%s\n' "${myconf[@]}" >> LOCAL.config ||
+ die "cannot create configuration"
+}
+
+src_compile() {
+ # The INSTALL script builds mk then [re]builds everything using that
+ einfo "Compiling Plan 9 from User Space can take a very long time"
+ einfo "depending on the speed of your computer. Please be patient!"
+ NPROC="$(makeopts_jobs)" ./INSTALL -b ||
+ die "Please report bugs to bugs.gentoo.org, NOT Plan9Port."
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ rm -rf src || die
+
+ # do* plays with the executable bit, and we should not modify them
+ dodir "${PLAN9}"
+ cp -a * "${ED}${PLAN9}" || die "cp failed"
+
+ # build the environment variables and install them in env.d
+ newenvd - 60plan9 <<-EOF
+ PLAN9="${EPLAN9}"
+ PATH="${EPLAN9}/bin"
+ ROOTPATH="${EPLAN9}/bin"
+ MANPATH="${EPLAN9}/man"
+ EOF
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}