summaryrefslogtreecommitdiff
path: root/dev-util/poke/poke-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-util/poke/poke-1.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-util/poke/poke-1.0.ebuild')
-rw-r--r--dev-util/poke/poke-1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/poke/poke-1.0.ebuild b/dev-util/poke/poke-1.0.ebuild
new file mode 100644
index 000000000000..0397a46a2393
--- /dev/null
+++ b/dev-util/poke/poke-1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="extensible editor for structured binary data"
+HOMEPAGE="http://www.jemarch.net/poke"
+
+SRC_URI="mirror://gnu/poke/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="machine-interface nls static-libs test"
+
+RESTRICT="!test? ( test )"
+
+# TODO: libnbd: not packaged in gentoo yet
+# TODO: gui: does not see to do anything :)
+RDEPEND="
+ dev-libs/boehm-gc:=
+ sys-devel/gettext
+ sys-libs/readline:=
+ machine-interface? ( dev-libs/json-c:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )
+"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-gui \
+ --disable-libnbd \
+ $(use_enable machine-interface mi) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}