summaryrefslogtreecommitdiff
path: root/dev-util/protobuf-cucumber
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-util/protobuf-cucumber
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-util/protobuf-cucumber')
-rw-r--r--dev-util/protobuf-cucumber/Manifest3
-rw-r--r--dev-util/protobuf-cucumber/metadata.xml10
-rw-r--r--dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/protobuf-cucumber/Manifest b/dev-util/protobuf-cucumber/Manifest
new file mode 100644
index 000000000000..fe3051ccd871
--- /dev/null
+++ b/dev-util/protobuf-cucumber/Manifest
@@ -0,0 +1,3 @@
+DIST protobuf-cucumber-3.10.8.gem 236544 BLAKE2B e81636fc06fbed54dc67def3d4d1c445a971d861e3dcd99aa406e137b858734d995100c76d33a6d00b6ec9584d8dbb8f1d05424e73d0f35a3d196cfb70ffc561 SHA512 904b3b6f0564a9db61c1b8e3aef10fe666dd602cf09c43c32241e908695b2f144be5e9ee094a21a07c43354ecaa3c9006ff62aa0e6f6ad2688b72bb9a40538a9
+EBUILD protobuf-cucumber-3.10.8.ebuild 916 BLAKE2B 1d0c1d97fc0c8c5b99754450a47d92db3f5bd3a4abaa113081287318e5d737386bdb5e64a5198940e04923cde926752ae2a2f51be451d48e51d4b4b1a6186575 SHA512 50c93a8045dd7b5d809edecc255f7ee03f7ef81229a3e35f1e8df084f85025586a3f68390d66f278e4533569023c7cf961db06c7beb6bf5b0f7cbad512d1b4fc
+MISC metadata.xml 304 BLAKE2B c9b85d55203c87d3e465d940748317de36c01c57ebedb89ca9ca7d671480bc1bbd8663e574b0571aabb65d18b18b9f2ece115a4edbce1918b536cd70d313517b SHA512 f39a76c9e9712656c87d5f3dfd937a3e246a0fa0ff50f5d6fb8e5f6de4e7e3d51b553c0e26e33cd6272c776480161e1103e6056222a1046caff368f249af2c16
diff --git a/dev-util/protobuf-cucumber/metadata.xml b/dev-util/protobuf-cucumber/metadata.xml
new file mode 100644
index 000000000000..31246c7969b9
--- /dev/null
+++ b/dev-util/protobuf-cucumber/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby-protobuf/protobuf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild b/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
new file mode 100644
index 000000000000..1d4dbac95549
--- /dev/null
+++ b/dev-util/protobuf-cucumber/protobuf-cucumber-3.10.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Google Protocol Buffers serialization and RPC implementation for Ruby"
+HOMEPAGE="https://github.com/ruby-protobuf/protobuf"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ >=dev-ruby/activesupport-3.2:*
+ dev-ruby/middleware
+ dev-ruby/thor:*
+ dev-ruby/thread_safe
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile spec/spec_helper.rb || die
+
+ # Avoid unpackaged optional dependency
+ rm -f spec/lib/protobuf/rpc/connectors/{ping,zmq}_spec.rb spec/functional/zmq_server_spec.rb || die
+ rm -rf spec/lib/protobuf/rpc/servers/zmq || die
+ sed -i -e '/context .zmq/,/^ end/ s:^:#:' spec/lib/protobuf/cli_spec.rb || die
+}