summaryrefslogtreecommitdiff
path: root/dev-util/radare2/radare2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/radare2/radare2-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/radare2/radare2-9999.ebuild')
-rw-r--r--dev-util/radare2/radare2-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/radare2/radare2-9999.ebuild b/dev-util/radare2/radare2-9999.ebuild
new file mode 100644
index 000000000000..4c5adb60d123
--- /dev/null
+++ b/dev-util/radare2/radare2-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+is_live() { [[ ${PV} == 9999* ]]; }
+
+is_live && inherit git-r3
+
+DESCRIPTION="Advanced command line hexadecimal editor and more"
+HOMEPAGE="http://www.radare.org"
+is_live || SRC_URI="http://www.radare.org/get/${P}.tar.xz"
+EGIT_REPO_URI="https://github.com/radare/radare2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ssl +system-capstone"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ system-capstone? ( dev-libs/capstone:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with system-capstone syscapstone)
+}