summaryrefslogtreecommitdiff
path: root/dev-util/ragel/ragel-7.0.0.10-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/ragel/ragel-7.0.0.10-r2.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/ragel/ragel-7.0.0.10-r2.ebuild')
-rw-r--r--dev-util/ragel/ragel-7.0.0.10-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-7.0.0.10-r2.ebuild b/dev-util/ragel/ragel-7.0.0.10-r2.ebuild
new file mode 100644
index 000000000000..c26cbce821da
--- /dev/null
+++ b/dev-util/ragel/ragel-7.0.0.10-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code"
+HOMEPAGE="https://www.colm.net/open-source/ragel/"
+SRC_URI="https://www.colm.net/files/ragel/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="vim-syntax"
+
+DEPEND="~dev-util/colm-0.13.0.5"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-use-pkginclude.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_test() {
+ cd "${S}"/test || die
+ ./runtests.in || die
+}
+
+src_install() {
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
+ fi
+ default
+ find "${D}" -name '*.la' -delete || die
+}