summaryrefslogtreecommitdiff
path: root/dev-util/re2c/re2c-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-util/re2c/re2c-1.3-r1.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-util/re2c/re2c-1.3-r1.ebuild')
-rw-r--r--dev-util/re2c/re2c-1.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-1.3-r1.ebuild b/dev-util/re2c/re2c-1.3-r1.ebuild
new file mode 100644
index 000000000000..d90e052b5214
--- /dev/null
+++ b/dev-util/re2c/re2c-1.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.org/"
+SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+PATCHES=("${FILESDIR}"/${P}-lexer-overflow.patch)
+
+src_configure() {
+ econf \
+ ac_cv_path_BISON="no" \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r README.md CHANGELOG examples
+}