summaryrefslogtreecommitdiff
path: root/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-util/rebar-bin/rebar-bin-3.16.1.ebuild')
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.16.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild b/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
new file mode 100644
index 000000000000..83bb5eb671c1
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://rebar3.org https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
+}
+
+src_install() {
+ dobin rebar3
+}