summaryrefslogtreecommitdiff
path: root/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-util/rebar-bin/rebar-bin-3.18.0.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-util/rebar-bin/rebar-bin-3.18.0.ebuild')
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.18.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild b/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild
new file mode 100644
index 000000000000..12502e7a00eb
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.18.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://rebar3.org https://github.com/erlang/rebar3"
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+
+QA_PREBUILT="usr/bin/rebar3"
+
+src_install() {
+ newbin "${DISTDIR}"/${P} rebar3
+}