summaryrefslogtreecommitdiff
path: root/dev-util/rebar-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-util/rebar-bin
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-util/rebar-bin')
-rw-r--r--dev-util/rebar-bin/Manifest3
-rw-r--r--dev-util/rebar-bin/metadata.xml28
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.6.2.ebuild31
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
new file mode 100644
index 000000000000..9ecaa14300ee
--- /dev/null
+++ b/dev-util/rebar-bin/Manifest
@@ -0,0 +1,3 @@
+DIST rebar3 694889 BLAKE2B 3a8f5562a0c984caf5d7b3ba1063a90bf110a60cea316eaf88f5199b890e186f85193dc0302b36dc31051d3552912c8d1582f563f989df97ee28364a3f47512a SHA512 8fb5c7737d70fc7a706b1e124ab660550e8637da9258338016ab2e260f1c6d662548ef723705cd18210050d052e79945578623d9e9892e08dbfdb9cb04fd89fb
+EBUILD rebar-bin-3.6.2.ebuild 590 BLAKE2B f9d0ca1c49a545709d17665e9872aee34f9a06d2c9711b5d0e701017c1b7e812ef7ff035ead1482640add65db692b8611900d62932ba5109aff766c140b755ec SHA512 725fb4d99ea3848e4a643714c01c4a7efc3230967df2bb8eef69069243e937c578ab21fc5a73a151339089761b4bd581fbf1990299d6b553d8ebe7ff902a1912
+MISC metadata.xml 1026 BLAKE2B e5a32a2acddabb427aed5d66ed8717fb56bc58938d389a05325765a182e6ba767d42011d95fa07e5faf2337bbba4d684d9c0802cfd3a815fb4459e8487d13c5e SHA512 537da2b6658cc8d0a2a2f90df63862afdfcdc326e4a930a059a3aef1f122f1a3f78ef11998e4e465b4d7463be6e3fbfbdd75ac78d5917a467cc9124da75bdfe4
diff --git a/dev-util/rebar-bin/metadata.xml b/dev-util/rebar-bin/metadata.xml
new file mode 100644
index 000000000000..56b1d345d115
--- /dev/null
+++ b/dev-util/rebar-bin/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ Rebar3 is an Erlang tool that makes it easy to create, develop, and
+ release Erlang libraries, applications, and systems in a repeatable
+ manner.
+
+ Rebar3 will:
+
+ - respect and enforce standard Erlang/OTP conventions for project
+ structure so they are easily reusable by the community;
+ - manage source dependencies and Erlang packages while ensuring
+ repeatable builds;
+ - handle build artifacts, paths, and libraries such that standard
+ development tools can be used without a headache;
+ - adapt to projects of all sizes on almost any platform;
+ - treat documentation as a feature, and errors or lack of documentation
+ as a bug.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">erlang/rebar3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
new file mode 100644
index 000000000000..9835d50cdf22
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" "${S}/" || die
+}
+
+src_install() {
+ dobin rebar3
+}