summaryrefslogtreecommitdiff
path: root/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 14:40:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 14:40:32 +0100
commit27f59f8e16510831cc751de1406f71afbf464653 (patch)
tree71463a2ac26fc948615ad34e8101c808c930f76f /dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild
parent9c572b23bc56215e9d24d375ddd293982c07dc08 (diff)
gentoo auto-resync : 24:10:2023 - 14:40:32
Diffstat (limited to 'dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild')
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild
new file mode 100644
index 000000000000..72bd53abb467
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_prepare() {
+ # the autodetection logic here is very very confused. This makes it not fail.
+ sed -i -e 's/if(${hsa-runtime64_FOUND})/if(false)/' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}