summaryrefslogtreecommitdiff
path: root/dev-util/rosinstall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/rosinstall
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/rosinstall')
-rw-r--r--dev-util/rosinstall/Manifest4
-rw-r--r--dev-util/rosinstall/metadata.xml11
-rw-r--r--dev-util/rosinstall/rosinstall-0.7.8.ebuild60
-rw-r--r--dev-util/rosinstall/rosinstall-9999.ebuild60
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-util/rosinstall/Manifest b/dev-util/rosinstall/Manifest
new file mode 100644
index 000000000000..75ac5cc5c9f1
--- /dev/null
+++ b/dev-util/rosinstall/Manifest
@@ -0,0 +1,4 @@
+DIST rosinstall-0.7.8.tar.gz 26430 BLAKE2B fae82276f5376a94914272e60b2e3b0f81cb37bd7b41e0a4df73c8b58d19a73505a0c5e193495fd59c931c04265cbb372abfad19fd4043fc77e5224127bd97f5 SHA512 a53ae8fb96f9dda4671b22dfd9dbadc18d1e4adbf34a50b6706baf971c1c7ee418e14641d334346b02638f06c10d1bc984b4759c92a39510dd0044fbc346be67
+EBUILD rosinstall-0.7.8.ebuild 1542 BLAKE2B 0956b9e0e7cbb58c7e7759bbfd64126ffdbafb682f9a1c14eee7a4461aae3fd619a4026554df070fbbfa73dcfc1e51b2c5564b35232fe5a90fc02e8ef89b4aef SHA512 c79f3206b128bcf405cd5ccf5f563887a848605f329810cbe588302d44c837569595eaa6399e8f39ada3e56a9c60fb8d3e7ab5e337fb6b0c190c44ca8d7609b4
+EBUILD rosinstall-9999.ebuild 1542 BLAKE2B 0956b9e0e7cbb58c7e7759bbfd64126ffdbafb682f9a1c14eee7a4461aae3fd619a4026554df070fbbfa73dcfc1e51b2c5564b35232fe5a90fc02e8ef89b4aef SHA512 c79f3206b128bcf405cd5ccf5f563887a848605f329810cbe588302d44c837569595eaa6399e8f39ada3e56a9c60fb8d3e7ab5e337fb6b0c190c44ca8d7609b4
+MISC metadata.xml 333 BLAKE2B 55190f2209aab41e0f1625fb699d61be2a53d0af996feff9ee5b0cbb5326363dcb915aa83427096f1723b885806a4cdb5b6cd2285c76064bf0b889b624fbcc31 SHA512 5c6ef4930985cd5c2ea51b18a25d7cc2a5e387bdbd26e42f8710d6ce903cf13fe85ee1f1d13a0ffe82c8056dd295a3e25268ec58353508f30bf10404ae4ffb8a
diff --git a/dev-util/rosinstall/metadata.xml b/dev-util/rosinstall/metadata.xml
new file mode 100644
index 000000000000..22544f9d5e39
--- /dev/null
+++ b/dev-util/rosinstall/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vcstools/rosinstall</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rosinstall/rosinstall-0.7.8.ebuild b/dev-util/rosinstall/rosinstall-0.7.8.ebuild
new file mode 100644
index 000000000000..34fc06b21e2a
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-0.7.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}
diff --git a/dev-util/rosinstall/rosinstall-9999.ebuild b/dev-util/rosinstall/rosinstall-9999.ebuild
new file mode 100644
index 000000000000..34fc06b21e2a
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}