summaryrefslogtreecommitdiff
path: root/dev-util/rr/rr-5.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-util/rr/rr-5.2.0-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-util/rr/rr-5.2.0-r1.ebuild')
-rw-r--r--dev-util/rr/rr-5.2.0-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/dev-util/rr/rr-5.2.0-r1.ebuild b/dev-util/rr/rr-5.2.0-r1.ebuild
deleted file mode 100644
index b60628ad4eec..000000000000
--- a/dev-util/rr/rr-5.2.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-CMAKE_BUILD_TYPE=Release
-
-inherit cmake-utils linux-info python-single-r1
-
-DESCRIPTION="Record and Replay Framework"
-HOMEPAGE="https://rr-project.org/"
-SRC_URI="https://github.com/mozilla/${PN}/archive/${PV}.tar.gz -> mozilla-${P}.tar.gz"
-
-LICENSE="MIT BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="multilib test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- sys-libs/zlib
- dev-libs/capnproto
- ${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- sys-devel/gdb[xml]"
-# Add all the deps needed only at build/test time.
-DEPEND+="
- test? (
- $(python_gen_cond_dep '
- dev-python/pexpect[${PYTHON_MULTI_USEDEP}]
- ')
- sys-devel/gdb[xml]
- )"
-
-RESTRICT="test" # toolchain and kernel version dependent
-
-PATCHES=(
- "${FILESDIR}"/${P}-ucontext_t.patch
- "${FILESDIR}"/${P}-c++14.patch
- "${FILESDIR}"/${P}-tgkill-glibc-2.30.patch
-)
-
-pkg_setup() {
- if use kernel_linux; then
- CONFIG_CHECK="SECCOMP"
- linux-info_pkg_setup
- fi
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i 's:-Werror::' CMakeLists.txt || die #609192
-}
-
-src_test() {
- if has usersandbox ${FEATURES} ; then
- ewarn "Test suite fails under FEATURES=usersandbox (bug #632394). Skipping."
- return 0
- fi
-
- cmake-utils_src_test
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- -Ddisable32bit=$(usex !multilib) #636786
- )
-
- cmake-utils_src_configure
-}