summaryrefslogtreecommitdiff
path: root/dev-util/sasm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/sasm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/sasm')
-rw-r--r--dev-util/sasm/Manifest4
-rw-r--r--dev-util/sasm/metadata.xml11
-rw-r--r--dev-util/sasm/sasm-2.2-r1.ebuild42
-rw-r--r--dev-util/sasm/sasm-9999.ebuild43
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/sasm/Manifest b/dev-util/sasm/Manifest
new file mode 100644
index 000000000000..c7f8761c5c31
--- /dev/null
+++ b/dev-util/sasm/Manifest
@@ -0,0 +1,4 @@
+DIST sasm-2.2.tar.gz 9117410 BLAKE2B f85d120469f11fd8cdb7ae9dcdc87464d8bc64db4f99cb2787c4f2adb6294288a7fd1dc071b53badb8153e8c8220a77964b102a234ad9ebc3b6a64d505c828dd SHA512 42d4af775d37d47bcf63fb70b9142e387e33cef5589002ff3e3cee926b5fca7e1508d640d1d5a175d48fc9fd041eb1f03304cad5ddc3c22a09ff29198650b513
+EBUILD sasm-2.2-r1.ebuild 749 BLAKE2B 336ff1f57eaf6fa9beef03f49b9b6082d45072e1e89927117e9d464a56edb6717e3cda8e72a02fbe9ebce398952c650ea7adca8afc9cbf29e718e2f3e688fd4c SHA512 7e049807b11fd7acbef12900decc451979818b413718e2935e6c28ec68ac7b0a70bfbe8316c407651bb66f336308157ba75ed77db0313b3ad45dbd81fcc6fddc
+EBUILD sasm-9999.ebuild 770 BLAKE2B c78133844ee317fbc57b7650359d56cf86ca102056b8241ced281450a8d755d9ab72b32aa2edf4901375bc634bac347041ecfa825fddec6e5b280fce4c26f10c SHA512 0dba9e85f0c9a638f82ef99f1a6deb4854c84f40ac2d8845f0d0dc155d22a84363af58a07e1ed4e32b9c797b1c4f4bb8ac0e35c77bbcccfc9c0718d62af59e27
+MISC metadata.xml 325 BLAKE2B 7fad0a2d1d4ab4f67758d702f18de025b6bf553e5f99ab43b6657ee9dbfcb858892ae5c4d6e37094b744b85fd70f1dd7f1b1e8e7ff142d86f9bf83190aa045c2 SHA512 8cb446410e74845234244cb121cf966f18ea1ce69796f6dc5c6c1d434952811e61c8b02aaeba24905578f8e8463e29269538b50768b30524af859419769b5a92
diff --git a/dev-util/sasm/metadata.xml b/dev-util/sasm/metadata.xml
new file mode 100644
index 000000000000..0dd346aa2e8d
--- /dev/null
+++ b/dev-util/sasm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Dman95/SASM</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/sasm/sasm-2.2-r1.ebuild b/dev-util/sasm/sasm-2.2-r1.ebuild
new file mode 100644
index 000000000000..7c9c73aab793
--- /dev/null
+++ b/dev-util/sasm/sasm-2.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/SASM-${PV}"
+fi
+
+DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
+HOMEPAGE="http://dman95.github.io/SASM/"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+REPEND="${DEPEND}
+ dev-lang/nasm
+ sys-devel/gdb
+"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}
diff --git a/dev-util/sasm/sasm-9999.ebuild b/dev-util/sasm/sasm-9999.ebuild
new file mode 100644
index 000000000000..61a911989dd0
--- /dev/null
+++ b/dev-util/sasm/sasm-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Dman95/SASM.git"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Dman95/SASM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/SASM-${PV}"
+fi
+
+DESCRIPTION="Simple crossplatform IDE for NASM assembly language"
+HOMEPAGE="https://dman95.github.io/SASM/"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+REPEND="${DEPEND}
+ dev-lang/nasm
+ sys-devel/gdb
+"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}