summaryrefslogtreecommitdiff
path: root/dev-util/scons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /dev-util/scons
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/Manifest1
-rw-r--r--dev-util/scons/scons-3.0.1-r100.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/scons/Manifest b/dev-util/scons/Manifest
index f95b70e2a856..c7f3347d4a92 100644
--- a/dev-util/scons/Manifest
+++ b/dev-util/scons/Manifest
@@ -15,6 +15,7 @@ DIST scons-3.0.1.tar.gz 634815 BLAKE2B f5bacec048969d592697bc3dfb44678c25a92982f
EBUILD scons-2.4.1.ebuild 1703 BLAKE2B 1fffba6edc3540869ce1af6c0a2e199614886610a464031395dd72e8f1311b703a398d9abb56eae9a67d4654529ec2fe06b8465f00fe83c442e251875dc53317 SHA512 69f7b513981e51bf547aad20f31af7ee98b77bb11bc10257499f92ea32d4a664cf83d77cabea81a56b068f2c18a40503567611e7ba78b987d4c6de1d52648b90
EBUILD scons-2.5.1.ebuild 1603 BLAKE2B 2469be4adae61636d044e2beec6bba28cb62bc81c6381d8eb1228a8907ae05c248ca042490cb4af0ef94bd1e081b950dfff064d07e194cba347e01c5ad647624 SHA512 1609e0aa9c7ac60e38aa92cae29d15bebec7583656d9f18cd545745f8fd29677fbd00643e617408866df88b42949c47de3405e2c57ddfde1e608a88a8ea83611
EBUILD scons-3.0.1-r1.ebuild 1967 BLAKE2B ae9dfc2809576dfa427c386d3943a15d39710f6401ea86ecc99f68420b11b07df817873b801df0a1802f0f51d973ee90bf7af2eceb79faabe39c70aa7972011b SHA512 58e7761c68debf79f1740f02800e94271b7339981696870411b8179b4e4e0156d8921b08c758f31ebf085da89fd4f0e880472787835ac2bc464c50a17df9a3c6
+EBUILD scons-3.0.1-r100.ebuild 2078 BLAKE2B 44634da960c7a30c9a0b8923cf163ea0be4ce31308d9b57d6705dc9baacd8661d62b317ad622f058cdfaae29728d781708df22021038281b83e9e9f0dda1db71 SHA512 f34c403ac05b2f42f3e1de1dd4ab3a3e22c3377f68ac0781da2a04280123cd218c912f5ff784876139b78cd93fe9b0dabd8d3304a4f3341f01645459a154f766
EBUILD scons-3.0.1-r2.ebuild 2063 BLAKE2B e2112913d1726903f0852585e3d93c029104fd83c5a598ebef1562e344e9c804d495669e74a2b9fe2f2e05362308fae60f29d3315ab028b72ee25a16830191e2 SHA512 a359c4f0dc2daea7dc12200d8dfeb91bd3e7d4768de2b807f82e863dd468251264e250061ec1088550d096a18005947a5f0f622aedf1eb721ce7cd920758d67c
EBUILD scons-3.0.1-r3.ebuild 2066 BLAKE2B 177a52afb4171023de660f6afdc0d895f5cc499b619c2d427354f8c99282eece6567c6b08c66b8dc9f644ca2b7d1ae216471c289c1030dbd0becd875c972108e SHA512 b88dd6016af45be90e31c761b276cb354bca00e28b3939bbe7f2b0a704620f46e71fc5b58dcc5553e10565413501c22d5c6e19d9a67cc99d267bd474493206e0
EBUILD scons-3.0.1.ebuild 1738 BLAKE2B eb1430c2c64fe79b36cf776b1df482726982e7b871393e5f1e829e2e5e02c21a1db129248121435b97bd8288f4aed5cbde3a0f167041d8a0c26fe86575903062 SHA512 1454bc63720c78d58362ae72d311d3fd4b81ef8b01900cb36f6cda2aab235d06a4fb6c2631927ac4efcee0fc761c6a672a925bda248a7def5d49b43529d042d8
diff --git a/dev-util/scons/scons-3.0.1-r100.ebuild b/dev-util/scons/scons-3.0.1-r100.ebuild
new file mode 100644
index 000000000000..93ab8b574de7
--- /dev/null
+++ b/dev-util/scons/scons-3.0.1-r100.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible Python-based build utility"
+HOMEPAGE="http://www.scons.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? (
+ http://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
+ http://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> ${P}-user.html
+ )
+ test? ( https://github.com/scons/scons/archive/${PV}.tar.gz -> ${P}.gh.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+S=${WORKDIR}/${P}/src
+
+PATCHES=(
+ # support env passthrough for Gentoo ebuilds
+ "${FILESDIR}"/scons-3.0.1-env-passthrough.patch
+ # respect CC, CXX, C*FLAGS, LDFLAGS by default
+ "${FILESDIR}"/scons-3.0.1-respect-cc-etc-r1.patch
+)
+
+src_unpack() {
+ # use the git directory structure, but put pregenerated release
+ # inside src/ subdirectory to make our life easier
+ if use test; then
+ unpack "${P}.gh.tar.gz"
+ rm -r "${P}/src" || die
+ else
+ mkdir "${P}" || die
+ fi
+
+ cd "${P}" || die
+ unpack "${P}.tar.gz"
+ mv "${P}" src || die
+}
+
+src_prepare() {
+ # apply patches relatively to top directory
+ cd "${WORKDIR}/${P}" || die
+ distutils-r1_src_prepare
+
+ # remove half-broken, useless custom commands
+ # and fix manpage install location
+ sed -i -e '/cmdclass/,/}$/d' \
+ -e '/data_files/s:man/:share/man/:' "${S}"/setup.py || die
+}
+
+python_test() {
+ cd "${WORKDIR}/${P}" || die
+ "${EPYTHON}" runtest.py -as \
+ -j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ --builddir "${BUILD_DIR}/lib" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( {CHANGES,README,RELEASE}.txt )
+ distutils-r1_python_install_all
+ rm "${ED%/}/usr/bin/scons.bat" || die
+
+ use doc && dodoc "${DISTDIR}"/${P}-user.{pdf,html}
+}