summaryrefslogtreecommitdiff
path: root/dev-util/shards
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-util/shards
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-util/shards')
-rw-r--r--dev-util/shards/Manifest5
-rw-r--r--dev-util/shards/shards-0.10.0.ebuild42
-rw-r--r--dev-util/shards/shards-0.9.0.ebuild24
3 files changed, 45 insertions, 26 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
index 4ef3d5a79632..8453975b1ba7 100644
--- a/dev-util/shards/Manifest
+++ b/dev-util/shards/Manifest
@@ -1,3 +1,4 @@
-DIST shards-0.9.0.tar.gz 41280 BLAKE2B a74ab96489c804da3017dc683295d1fc16ba30248015af9deccdcf52a09301f665d4848822419d263d2301969c484fae288eff63e281bd4841b1fd101c5d5383 SHA512 a06579f1a96cea1fb1ba97c17ae4529439fb7c54572e74b4969921b1a987a1e1be9c9eb8569db94fd4cb4adc098b3085abfd2a6f7015da7f39611a1774d30022
-EBUILD shards-0.9.0.ebuild 515 BLAKE2B a16c770f6fe242ae766feb2965e55250817447d7374073a3114a4ec793ce18191bb3c994e22b1506485779042b960ca1228185ba6b3dcd4818231c728c4320c7 SHA512 1fdd2d1bb39cf2db2c203d87246e991bf0d1c638b8684f5463f398ad080e683db5db53c001c5edee368df3d61a3d5112257c82514323b95990e6808c670aeff5
+DIST crystal-molinillo-0.1.0.tar.gz 23932 BLAKE2B c9bcd707a3208f5d80e6e3030523d50f86cb5977799de8ea6035d014094e3c2fff9bb189fa98f566e72e1e7ad161e47e44c89d9b264d47f109b2e891ecb469e5 SHA512 8d74d95896cd7ff510c87e2ffba6ae5f04ceeddde574930ee609851312b65d713a315cc24f9aa3fab02f9447ccb25ef2dd2e8179640b8c5cfb3d7d6b52d1ded5
+DIST shards-0.10.0.tar.gz 39507 BLAKE2B f6b6034a626500d0459e01be73de28506dc2efe116a5f662b27edb6cbe363cf4bb3184fcce83838e02dec4db18355a85737b4783560b7d94b643145d08581174 SHA512 8d41a2553fd99bd44a3e8a9aacbd17f2a1e9f8730f90c4682091e8d2a4f2388818bdfc4e4bf654c3cbebd617a74474fb63f1fb86a62998cf79409d4778649757
+EBUILD shards-0.10.0.ebuild 929 BLAKE2B 7d8e32a3c01039c1b361e7689209d99d3b0fcfbdd942a34aad4917ae64f04bf592de8bac87ec36f690d0828f6126cc0d710b29fd72a179d056e98a2b821e4ae3 SHA512 4e314b9093b90d2cf22038d3e3c4b8c39f269584166985f3c7af81a4c478f2fb1c8daaa00af71e944ab1fbe99395bef9dd8bec0acc4c6584ee4cc70ecebee9b1
MISC metadata.xml 334 BLAKE2B 9958fd270de05b67ac94b791633635bd62770ad0ebe44630e43c26933d2059d042bc00997a8b5b8983c0e839a8adaf238359a17285e4bf8321f082077baaabbc SHA512 8010e36b15550ce7e599e30f1716b3df9d17f464f01cad097e829f3ec97624578f9bb7e24f832e14c67b4cdd5c8d25c998282e39ea0341e81baff39c1bcae658
diff --git a/dev-util/shards/shards-0.10.0.ebuild b/dev-util/shards/shards-0.10.0.ebuild
new file mode 100644
index 000000000000..c36571a58c8e
--- /dev/null
+++ b/dev-util/shards/shards-0.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.1.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}
diff --git a/dev-util/shards/shards-0.9.0.ebuild b/dev-util/shards/shards-0.9.0.ebuild
deleted file mode 100644
index c11e7698cd9b..000000000000
--- a/dev-util/shards/shards-0.9.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Dependency manager for the Crystal language"
-HOMEPAGE="https://github.com/crystal-lang/shards"
-SRC_URI="https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="
- >dev-lang/crystal-0.11.1[yaml]
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT=test # missing files in tarball
-
-src_install() {
- dobin bin/${PN}
- dodoc README.md
-}