summaryrefslogtreecommitdiff
path: root/dev-util/shc/shc-3.8.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/shc/shc-3.8.9.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/shc/shc-3.8.9.ebuild')
-rw-r--r--dev-util/shc/shc-3.8.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/shc/shc-3.8.9.ebuild b/dev-util/shc/shc-3.8.9.ebuild
new file mode 100644
index 000000000000..78178e4f1ae1
--- /dev/null
+++ b/dev-util/shc/shc-3.8.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A (shell-) script compiler/scrambler"
+HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ~sparc x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ # respect LDFLAGS
+ sed -i makefile -e 's:$(CC) $(CFLAGS):& $(LDFLAGS):' || die
+ # fix source file name wrt bug #433970
+ mv {${P},${PN}}.c || die
+}
+
+src_compile() {
+ ## the "test"-target leads to an access-violation -> so we skip it
+ ## as it's only for demonstration purposes anyway.
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" shc
+}
+
+src_install() {
+ dobin shc
+ doman shc.1
+ newdoc shc.README README
+ dodoc CHANGES
+}