summaryrefslogtreecommitdiff
path: root/dev-util/shellcheck/shellcheck-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/shellcheck/shellcheck-0.8.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/shellcheck/shellcheck-0.8.0.ebuild')
-rw-r--r--dev-util/shellcheck/shellcheck-0.8.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/shellcheck/shellcheck-0.8.0.ebuild b/dev-util/shellcheck/shellcheck-0.8.0.ebuild
new file mode 100644
index 000000000000..c5dd28f791b4
--- /dev/null
+++ b/dev-util/shellcheck/shellcheck-0.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ShellCheck"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Shell script analysis tool"
+HOMEPAGE="https://www.shellcheck.net/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/diff-0.2.0:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?]
+ >=dev-haskell/parsec-3.0:=[profile?]
+ >=dev-haskell/quickcheck-2.7.4:2=[template-haskell,profile?]
+ dev-haskell/regex-tdfa:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"