summaryrefslogtreecommitdiff
path: root/dev-util/shunit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/shunit2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/shunit2')
-rw-r--r--dev-util/shunit2/Manifest3
-rw-r--r--dev-util/shunit2/metadata.xml14
-rw-r--r--dev-util/shunit2/shunit2-2.1.6-r1.ebuild26
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/shunit2/Manifest b/dev-util/shunit2/Manifest
new file mode 100644
index 000000000000..54dd62418803
--- /dev/null
+++ b/dev-util/shunit2/Manifest
@@ -0,0 +1,3 @@
+DIST shunit2-2.1.6.tgz 61558 BLAKE2B 0568dbe6ff9234346d85925a7f27dc2c8e9003a3266ef0bf7c1bb5f73e06ce758c7ff82933899c9a99e37c189d2efdc111fe5132c69a4d80535dc4d14b7ec8d5 SHA512 c78cf349d72a9048e4932108a62b2d1873019b9b1909c3fb1bd7e873e7bb62df58c1941d916508dc60ef6ba0261a2bc6ee9e25d654eefdcce997682f2bc748d7
+EBUILD shunit2-2.1.6-r1.ebuild 547 BLAKE2B f85d146421c60c42669c418c596cb078b3ac1b402d8bd4687d684a9c3e56a8ee0fe2994cf7cd3e69f437e7a87bf1ed60cf8809220d69841eaf3932feebbd6b07 SHA512 617fdbc114ac334c52fbfa0d5580a062799f8aebf03a16398ef786f8ffd28140273161d18b468665f8dd2ccce93d43d93c10f1170c8e6d8573ce8124935b8251
+MISC metadata.xml 554 BLAKE2B fa966d5f0a498ec0c3327ce604f1a628120c138510890a59c0bc12fd955300cd2e399d6e36fa9720138713a5365751051ce83cd743bc7aabaddda65f5b08e446 SHA512 a548ed7c3551878031b1df0a9c45886e46271034f477f1c34ed1cea69c750176875a61ad526ecc59df5a59aa5c22fc0948ca2cf831feee5bb1178cfb76849dea
diff --git a/dev-util/shunit2/metadata.xml b/dev-util/shunit2/metadata.xml
new file mode 100644
index 000000000000..45da850feec0
--- /dev/null
+++ b/dev-util/shunit2/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ shUnit2 is a xUnit unit test framework for Bourne based shell scripts, and
+ it is designed to work in a similar manner to JUnit, PyUnit, etc. If you
+ have ever had the desire to write a unit test for a shell script, shUnit2
+ can do the job.
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">shunit2</remote-id>
+ <remote-id type="github">kward/shunit2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/shunit2/shunit2-2.1.6-r1.ebuild b/dev-util/shunit2/shunit2-2.1.6-r1.ebuild
new file mode 100644
index 000000000000..dd75e0e1c249
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts"
+HOMEPAGE="https://github.com/kward/shunit2"
+SRC_URI="https://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_install() {
+ dobin src/shunit2
+
+ # For backwards compat to <=2.1.5
+ dosym /usr/bin/shunit2 /usr/share/shunit2/shunit2
+
+ dodoc -r examples
+ dodoc doc/*.txt
+
+ docinto html
+ dodoc doc/*.{html,css}
+}