summaryrefslogtreecommitdiff
path: root/dev-util/source-highlight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /dev-util/source-highlight
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/Manifest1
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-util/source-highlight/Manifest b/dev-util/source-highlight/Manifest
index d9ac9af459f3..63f6d3f14e67 100644
--- a/dev-util/source-highlight/Manifest
+++ b/dev-util/source-highlight/Manifest
@@ -2,4 +2,5 @@ AUX source-highlight-3.1.9-test-clang-p1.patch 998 BLAKE2B 7867aff751170990c4834
AUX source-highlight-3.1.9-test-clang-p2.patch 1413 BLAKE2B f66b090bb5004cf4ee344868479b1a1999339d71799e6e6150104f99c0a8ea5ffebe836b8d185ecb52416aaed6da80e24c5870910274ce381cfab6ab3276035c SHA512 a6573d376753dda6e8f64dd9b81c4e8f209ea5cb3dee1dc9a495db6b671d88840baa2fd9c128085cb62d9acbc41e1f88d3a9e6a319b76199755b43008d7ab0de
DIST source-highlight-3.1.9.tar.gz 1717234 BLAKE2B 6eb40b2274df0772c4a241504e5db5dfdaac600549e0b11aba726f7b4d5ab600c3849a8815bc782ad1bb1f99b69766527645dd202731bde4b2466c663842c47c SHA512 d8e154e9a5d62c77807e4e5d36c0faed5ce2964291be5f8b83e2968a6de52229503689a4ca2109a717ae2632a14b63ec937ca0430c91684c72063f6bc0294195
EBUILD source-highlight-3.1.9-r1.ebuild 1476 BLAKE2B 3e58b200d93c08decbaf5da28a760977189860c8967df8ebf349e79ecc0adbb7db506eed49efa361c8861954d6975fe58193a7aa878c787012b61be95e71320e SHA512 262e274d0266f9272e125e6f74074c201e379278a96439653261084fd7195c98e5491fbfa0a1c3d796281e70771c0f04ccd082417d934537137302c4084800c7
+EBUILD source-highlight-3.1.9-r2.ebuild 1820 BLAKE2B f0f3eecc97c929f299444525be120a6b15f59a62866e4a287a12ef8ac1e7dd2a7bb2d5d1ae46423951152381163d5fb698ed4047203bf8732d76b7a2864671a2 SHA512 7f5ea4384b1feac3475cf6b42f7056de60d1535c65734c53dae6b297f0f1ca2ac855f140aaec3afd9584c635055cadbc7db812d6cf0d9050d4752dccc102763a
MISC metadata.xml 268 BLAKE2B 8482f168e8ebdc914b137d3b41df6840c3478b8898d5278c5d43742538d0edb403505d66583f44b142b094f8735777d79637b69b6fcb3b7cd7026e415eb48e58 SHA512 433cd6a955f0104f3767d50ab08e08e79c8ca4276a56c2cd284692472cf5f19918d1ff22539eedf0232224193c15d6c84198c95647ed390f2b520d05211de721
diff --git a/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild b/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
new file mode 100644
index 000000000000..cb29e05a42f8
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 flag-o-matic libtool optfeature
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-util/ctags )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.9-test-clang-p1.patch
+ "${FILESDIR}"/${PN}-3.1.9-test-clang-p2.patch
+)
+
+src_prepare() {
+ default
+
+ # Although all unpatched libtools are probably broken, this one ignores LTO
+ # warning flags.
+ elibtoolize
+}
+
+src_configure() {
+ # required as rev-dep of dev-libs/boost-1.62.0
+ # https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI
+ append-cxxflags -std=c++14
+ # ODR violations: https://savannah.gnu.org/bugs/index.php?65086
+ filter-lto
+
+ econf \
+ --with-boost="${EPREFIX}/usr" \
+ --with-boost-regex="boost_regex" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ # upstream uses the same temporary filenames in numerous places
+ # see https://bugs.gentoo.org/635100
+ emake -j1 check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/*.{html,css,java} )
+ default
+
+ # That's not how we want it
+ rm -rf "${ED}"/usr/share/{aclocal,doc} || die
+
+ # package provides .pc file
+ find "${D}" -name '*.la' -delete || die
+
+ dobashcomp completion/source-highlight
+}
+
+pkg_postinst() {
+ optfeature "ctags support" dev-util/ctags
+}