summaryrefslogtreecommitdiff
path: root/dev-util/stepman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-util/stepman
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-util/stepman')
-rw-r--r--dev-util/stepman/Manifest3
-rw-r--r--dev-util/stepman/metadata.xml20
-rw-r--r--dev-util/stepman/stepman-0.10.0.ebuild39
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/stepman/Manifest b/dev-util/stepman/Manifest
new file mode 100644
index 000000000000..f2cd68e028e3
--- /dev/null
+++ b/dev-util/stepman/Manifest
@@ -0,0 +1,3 @@
+DIST stepman-0.10.0.tar.gz 3054342 BLAKE2B 8d1d6fc8b4b85c79d535c6162a8b7c5ba15042b6a8334286cdf7ad5d498ee20abecaa1bb9ce9ffe5406891271e23a2e2554bea0b52bbf08df23a2154fdcb4da8 SHA512 1437d5c997e62a9da3beb666a15ac665e18300fad3668ee3acdae30307027bbf16c0d95f649a9a62c6203f3e09f9ec83525a23b3789f09c3707ff1937a7affbe
+EBUILD stepman-0.10.0.ebuild 962 BLAKE2B d83a3ee4b3169a85604fd93d8de9ca2b54ccc2c7e47592d98236eda93dd2edc8ef080de477906e2f305d6e855402fdecf60e74b2c6dc959afff19bae1799a78d SHA512 09686058814adcb51f743b97410ea933b4122dbf2b96ace3ddad51499d50f867fb65e253c3ec9c23ed7334fb3b0d26ceb6477d9130bcf96f91d4071edb6eb1c4
+MISC metadata.xml 949 BLAKE2B 883da9ca0b0e0d8d86e6c4e863eea1f53a029c4d5ee517ca546a70ea34180055dd3500a7f85c4cf98571f9f487ac78cb86b48a772992a4461aa0342b12def494 SHA512 db268017d243e1e24b2ea28731e8286f731bbb73214f17828d4a86dba4fd2a7c4e259f8afb2698984569bcd20b06029cfb3be45fbf8e84934ca650ee842f2a17
diff --git a/dev-util/stepman/metadata.xml b/dev-util/stepman/metadata.xml
new file mode 100644
index 000000000000..a84ba4077979
--- /dev/null
+++ b/dev-util/stepman/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>karol.wrotniak@droidsonroids.pl</email>
+ <name>Karol Wrótniak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Step collection manager for Bitrise CLI. Part of the Bitrise Continuous Integration, Delivery and Automations Stack, with envman and bitrise. For a nice &amp; quick intro you
+should check: https://www.bitrise.io/cli</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bitrise-io/stepman/issues</bugs-to>
+ <changelog>https://github.com/bitrise-io/stepman/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/bitrise-io/stepman/blob/master/README.md</doc>
+ <remote-id type="github">bitrise-io/stepman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/stepman/stepman-0.10.0.ebuild b/dev-util/stepman/stepman-0.10.0.ebuild
new file mode 100644
index 000000000000..4b0b891bc494
--- /dev/null
+++ b/dev-util/stepman/stepman-0.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Step collection manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
+}
+
+src_test() {
+ export INTEGRATION_TEST_BINARY_PATH="${S}/bin/stepman"
+ GOPATH="${WORKDIR}" go test -v ./_tests/integration/... || die "Integration tests failed"
+}
+
+src_install() {
+ dobin bin/stepman
+ dodoc README.md
+}