summaryrefslogtreecommitdiff
path: root/dev-util/sysdig/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-util/sysdig/files
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-util/sysdig/files')
-rw-r--r--dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch b/dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch
new file mode 100644
index 000000000000..eaf689a54d0d
--- /dev/null
+++ b/dev-util/sysdig/files/sysdig-0.27.1-grpc-absl-sync.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/817128
+https://github.com/hhoffstaette/portage/blob/master/dev-util/sysdig/files/0.27.1-grpc-absl-sync.patch
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -552,6 +552,7 @@ if(NOT WIN32 AND NOT APPLE)
+ else()
+ message(FATAL_ERROR "Couldn't find system grpc")
+ endif()
++ find_library(ABSL_SYNC_LIB NAMES absl_synchronization)
+ find_program(GRPC_CPP_PLUGIN grpc_cpp_plugin)
+ if(NOT GRPC_CPP_PLUGIN)
+ message(FATAL_ERROR "System grpc_cpp_plugin not found")
+--- a/userspace/libsinsp/CMakeLists.txt
++++ b/userspace/libsinsp/CMakeLists.txt
+@@ -214,6 +214,10 @@ if(NOT WIN32)
+ "${JQ_LIB}"
+ "${B64_LIB}")
+
++ if(ABSL_SYNC_LIB)
++ target_link_libraries(sinsp "${ABSL_SYNC_LIB}")
++ endif()
++
+ if(NOT MUSL_OPTIMIZED_BUILD)
+ target_link_libraries(sinsp
+ rt