summaryrefslogtreecommitdiff
path: root/dev-util/tailor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/tailor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/tailor')
-rw-r--r--dev-util/tailor/Manifest3
-rw-r--r--dev-util/tailor/metadata.xml10
-rw-r--r--dev-util/tailor/tailor-0.9.35-r1.ebuild36
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/tailor/Manifest b/dev-util/tailor/Manifest
new file mode 100644
index 000000000000..ab32c69149c2
--- /dev/null
+++ b/dev-util/tailor/Manifest
@@ -0,0 +1,3 @@
+DIST tailor-0.9.35.tar.gz 228650 BLAKE2B 00f609b64f22f35791bcbced1d5e62aa38b3d00c88b5d96f525807991cc51e5e82e2312583c257fc039bf89d794bcf3dbe9580e582f0d3d638289399808194ed SHA512 184521adac681ccca279215c115913d98d1521aac41fe15ca65a35e3c5075419e1cb0f1b453bca6d5a56a15b09928c34738a264b44f666de7067b2aba0562bed
+EBUILD tailor-0.9.35-r1.ebuild 868 BLAKE2B f3209f65373063f0c7b2e1b3e2c1294010513b35962b5c2e78d326ab0f833f0c088c7acf9a4b0dffe67c6811afd2ec52d542d2c0e6b0053c5f3ee1533fdf93a1 SHA512 2047073ec9dbc72d66bc99d773769aa37ee4c7a2ba4d562ee0ffb7c8628d305d35820c7cfea95829943bc8673129033ef5e313c1d4c0b9c9aed7b53e5e9f11ea
+MISC metadata.xml 375 BLAKE2B 33ebd2d721501f15f3688440fea5ee396d7a2edc27f8c8443f71a2a21091db612bd7b1de7b5e811f624a49531081642292e4957fc52881a20663bcb470147773 SHA512 941495f6fcaf8a68c320ad045533fa95a7deab3ec1cf2b55113c67efe004045685464440eaaf4b879711389c9b4afd21eccc74c2be865ce59b1216c206bb8877
diff --git a/dev-util/tailor/metadata.xml b/dev-util/tailor/metadata.xml
new file mode 100644
index 000000000000..8dd954b0400b
--- /dev/null
+++ b/dev-util/tailor/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ Tailor is a tool to migrate changesets between ArX, Bazaar,
+ Bazaar-NG, CVS, Codeville, Darcs, Git, Mercurial, Monotone,
+ Subversion and Tla repositories.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/tailor/tailor-0.9.35-r1.ebuild b/dev-util/tailor/tailor-0.9.35-r1.ebuild
new file mode 100644
index 000000000000..baf62a2442bd
--- /dev/null
+++ b/dev-util/tailor/tailor-0.9.35-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to migrate changesets between version control systems"
+HOMEPAGE="http://wiki.darcs.net/index.html/Tailor"
+SRC_URI="http://darcs.arstecnica.it/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_install_all() {
+ local HTML_DOCS=( README.html )
+ distutils-r1_python_install_all
+ rm "${D}usr/share/doc/${PF}/README.html"
+}
+
+pkg_postinst() {
+ elog "Tailor does not explicitly depend on any other VCS."
+ elog "You should emerge whatever VCS(s) that you want to use seperately."
+}