summaryrefslogtreecommitdiff
path: root/dev-util/tbump
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-04 12:28:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-04 12:28:34 +0100
commit518b45bffd19d0b75715f338985f96c459f9d129 (patch)
tree948dfe5d479374fd6b85fe72ff2570e8a4af47ff /dev-util/tbump
parent3f559ef486314f9b3b48d48eb303d6be68463af9 (diff)
gentoo auto-resync : 04:09:2024 - 12:28:34
Diffstat (limited to 'dev-util/tbump')
-rw-r--r--dev-util/tbump/Manifest3
-rw-r--r--dev-util/tbump/metadata.xml18
-rw-r--r--dev-util/tbump/tbump-6.11.0.ebuild45
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/tbump/Manifest b/dev-util/tbump/Manifest
new file mode 100644
index 000000000000..cee6fb411587
--- /dev/null
+++ b/dev-util/tbump/Manifest
@@ -0,0 +1,3 @@
+DIST tbump-6.11.0.tar.gz 28642 BLAKE2B 2e45fbf1d3e824b0f63f79db0928895488fb06a657c85335235d9aede8576f12bc2e8be58006e2883fb8d639d63029decdc7377dfaeda5d87475e505a4a22fe2 SHA512 3bcd6d34dab2f323dba45dd29053da5a75b5ec9f88aad1d50a2dd1a1d43fe7200bc58742c56249dd167b12e9dc599783eba93adac52e7d87aaa2e7e74f43a532
+EBUILD tbump-6.11.0.ebuild 1016 BLAKE2B ba8a464c10bcf929998c03f3fadefb52d6d930e256477b2d431649ee02ac83683f0da2a0d9072a93e8403a28c565f481f050554c7aa33e9538125133fa0d0f63 SHA512 aebb0368260e000d7da6dcaf60627e843329a6e733a11f00ccf0163a4f0b2f0df9199fdf25e23e84408e9b555dd5e0298f8a3f2c8807e827d7907338a0800e4c
+MISC metadata.xml 555 BLAKE2B 605a19bbcf3288b89c7dd196a067d2be04ee1dcf3456405b15c7b9dd6c1f00afcb243014f1b41cbdbfd0c7137a6a993a06c84a2c0aecb76f0708ae9b37e1f1f6 SHA512 6c37e2bfa631281347f76f9ea89bd265ecc7e2364f1f5276ff3f2ef5ab8914483ab7914c2d4bf8d40ab247d466e0b3b620b49a85083f6c02920b072185d003c9
diff --git a/dev-util/tbump/metadata.xml b/dev-util/tbump/metadata.xml
new file mode 100644
index 000000000000..59e126ffa3be
--- /dev/null
+++ b/dev-util/tbump/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/your-tools/tbump/issues/</bugs-to>
+ <remote-id type="github">your-tools/tbump</remote-id>
+ <remote-id type="pypi">tbump</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/tbump/tbump-6.11.0.ebuild b/dev-util/tbump/tbump-6.11.0.ebuild
new file mode 100644
index 000000000000..b0ca5dc36fb9
--- /dev/null
+++ b/dev-util/tbump/tbump-6.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="poetry"
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="tbump helps you bump the version of your project easily"
+HOMEPAGE="https://github.com/your-tools/tbump/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/your-tools/tbump.git"
+else
+ inherit pypi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/cli-ui[${PYTHON_USEDEP}]
+ dev-python/schema[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ "tbump/test/test_api.py"
+ "tbump/test/test_cli.py"
+ "tbump/test/test_file_bumper.py::test_file_bumper_preserve_endings"
+ "tbump/test/test_file_bumper.py::test_file_bumper_simple"
+ "tbump/test/test_git_bumper.py"
+ "tbump/test/test_hooks.py"
+ "tbump/test/test_init.py"
+)
+
+distutils_enable_tests pytest