summaryrefslogtreecommitdiff
path: root/dev-util/tinycmmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
commit20325cfc3bd40d48d3c7034afaac4f5193d9c704 (patch)
treeb8e6ff7fc02271595e20f956b32cef56c41dafca /dev-util/tinycmmc
parent14a6858a7d8bc085420a1430b3a3f67885019f27 (diff)
gentoo auto-resync : 29:08:2023 - 10:04:54
Diffstat (limited to 'dev-util/tinycmmc')
-rw-r--r--dev-util/tinycmmc/Manifest4
-rw-r--r--dev-util/tinycmmc/metadata.xml15
-rw-r--r--dev-util/tinycmmc/tinycmmc-0.1.0.ebuild20
-rw-r--r--dev-util/tinycmmc/tinycmmc-9999.ebuild20
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/tinycmmc/Manifest b/dev-util/tinycmmc/Manifest
new file mode 100644
index 000000000000..cbcc2b98a493
--- /dev/null
+++ b/dev-util/tinycmmc/Manifest
@@ -0,0 +1,4 @@
+DIST tinycmmc-0.1.0.tar.gz 10559 BLAKE2B 9708c6c95c5746d000bb02b46bc40b788b8b18d55d3bd2e97e88789f4b084e145db39e038b4d619c75273b8fd23713f6906a8618fa248664a468c60e1073000c SHA512 cf1e8108be2f5c8a23e08756b6f50a2493a688ffa8bd7a06a59330cdd74046035705f18d5f53a00d6779dafb76a2c529b4ca9be7e53ff2660d718e8f68544769
+EBUILD tinycmmc-0.1.0.ebuild 440 BLAKE2B 22bfe8ee885011786b41eaffed3edc427921086cac66bb3ecf3d494e2d6c9dec6a64eec2afce0b9ffe772e58a03a0dc9e3a9c8b7a2cae0e76648471ef9f1d33a SHA512 88a2d143fc2c3f5db8e964db71b0b1ee81f652f56213150d72e4e291e51e88d971a175cdeed8fe24832512d558a8bd894642d5f37f0f83f0bae2b9dc44058d0d
+EBUILD tinycmmc-9999.ebuild 438 BLAKE2B f2efba8224cde6c3099d5551dcfedf3dd714e381c2e55b7dc93e194d206752d6a680d7fb48dc807eb855793b62cfef810b1035f538db91e460ad5bb1bf04712c SHA512 cab8f8d6aaba6b6729a9f17cfe34222b5c6f2be3009b5a747a954ff2bb6b3f1eb791fbc3af8e639f90806465b0b83cfc8007c48cfe6e599e1bdaca28f8aa822c
+MISC metadata.xml 466 BLAKE2B 2fe1efd4c596f9c0023f6f6758da754cda0467f615798ff4f9eda4c9a4500db4364415ce14277dfbe40fdf1babde0a8ebd1ba636b58cb2776fc63ed977498304 SHA512 c0bf3b4a08ef90c34d7dfa222b59fb38cc6590465b9b2a93d5cbc501794f6ed36fc76ce971da04f495262964f4f7e8e659770881f7cb8308617ed60655b515c6
diff --git a/dev-util/tinycmmc/metadata.xml b/dev-util/tinycmmc/metadata.xml
new file mode 100644
index 000000000000..a85353b5969e
--- /dev/null
+++ b/dev-util/tinycmmc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Grumbel/tinycmmc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/tinycmmc/tinycmmc-0.1.0.ebuild b/dev-util/tinycmmc/tinycmmc-0.1.0.ebuild
new file mode 100644
index 000000000000..d36c835eb825
--- /dev/null
+++ b/dev-util/tinycmmc/tinycmmc-0.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="GPL-3+"
+SLOT="0"
diff --git a/dev-util/tinycmmc/tinycmmc-9999.ebuild b/dev-util/tinycmmc/tinycmmc-9999.ebuild
new file mode 100644
index 000000000000..ecaf99a1a6db
--- /dev/null
+++ b/dev-util/tinycmmc/tinycmmc-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="ZLIB"
+SLOT="0"